The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

pure-ftpd :: login failed

Discussion in 'General Discussion' started by mpregent, May 28, 2005.

  1. mpregent

    mpregent Member

    Joined:
    Jun 28, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    hi,

    i created a normal user through ssh useradd, but i cannot login to ftp with it. does anyone know how to fix this probem?
     
  2. ehpmahesh

    ehpmahesh Well-Known Member

    Joined:
    Jul 3, 2004
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    What are the entry you are giving like hostname and username and password.
    Make sure that you are giving correct entry. Let us know what error you are getting.
    For details you can check ftp logs.
     
  3. mpregent

    mpregent Member

    Joined:
    Jun 28, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    hostname: surfwebtechnology.com
    username: madboy

    220---------- Welcome to Pure-FTPd [TLS] ----------
    220-You are user number 1 of 50 allowed.
    220-Local time is now 22:07. Server port: 21.
    220 You will be disconnected after 15 minutes of inactivity.
    Host type (1): Automatic detect
    USER madboy
    331 User madboy OK. Password required
    PASS (hidden)
    530 Authentication failed, sorry


    where do i find the ftp logs?
     
  4. anup123

    anup123 Well-Known Member

    Joined:
    Mar 29, 2004
    Messages:
    897
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    This Planet
    It will not work .. it has never worked whenever i changed user password from ssh.
    Login to WHM and try Resync FTP password or something like that link is there.... thereafter it should work ... works in my case whenever i do a passwd username from ssh

    Anup
     
  5. ehpmahesh

    ehpmahesh Well-Known Member

    Joined:
    Jul 3, 2004
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    You can check xfer log to check ftp log. As per your log it is showing that 530 Authentication failed, sorry it means that it is not taking your password. Also check useradd created /home/madboy directory.
     
  6. mpregent

    mpregent Member

    Joined:
    Jun 28, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    thx doing a resync from whm worked:)
     
  7. anup123

    anup123 Well-Known Member

    Joined:
    Mar 29, 2004
    Messages:
    897
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    This Planet
    This is a serious problem. I never really tried changing root password from ssh and then logging off. If the same is reproducible then i am done for the day. So for password changing i always prefer doing it from WHM. Yes for ftpd it's reproducible any number of times user password is changed from ssh.

    Anup
     
  8. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    It won't work if you change a password using passwd because IIRC (and oddly) pure-ftpd on cPanel uses the /etc/proftpd/passwd.vhosts file for authentication, not /etc/passwd and so you have to sync the passwords in WHM which basically copies the passwd record into the pure-ftpd auth file.
     
  9. romanus

    romanus Well-Known Member

    Joined:
    Jul 17, 2004
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    where is the resync option in whm please? Thanks
     
  10. RickG

    RickG Well-Known Member

    Joined:
    Feb 28, 2005
    Messages:
    238
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    North Carolina
    Its under the cPanel section and called "Synchronize FTP Passwords"
     
Loading...

Share This Page