Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Pure-FTPD Passive

Discussion in 'General Discussion' started by kris1351, Apr 10, 2006.

  1. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Lewisville, Tx
    With each update there is always something new and fun. I am using kernel 2.6.16 SMP now instead of just the plain vanilla kernel. That fixed the known issues with Centos 4.x and its memory usage, but now I cannot get passive FTP to work at all. I had to enable the MONOKERN option in APF to get APF to work and that is when passive blew up.

    Active FTP works, SFTP works and SCP works but as we all know the passive is what customers want so I have to figure out a quick solution. I have attempted to just manually open the ports using /etc/pure-ftpd.conf and the APF in/outs, but that does not work. Anyone else had a similar issue or have a fix for this?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    22
    Trophy Points:
    463
    Location:
    Go on, have a guess
    If it works with APF disabled, then it's a bug in APF - I've seen it many times with APF and it's yet to be fixed by the developer (been going on for months now). If opening a nice big hole in iptables doesn't work with APF, then I'd suggest trying a different iptables script.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice