The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

pure-ftpd restricting # of files displayed

Discussion in 'General Discussion' started by mrprez, Dec 11, 2002.

  1. mrprez

    mrprez Well-Known Member

    Joined:
    Jun 14, 2002
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    16
    Pure-ftpd is limiting the number of files displayed to 2000. This is causing problems and I need to adjust this level. I edited /etc/pure-ftpd.conf but the changes did not take effect. I did restart FTP.

    Anyone have any ideas?

    John
     
  2. bmcclure

    bmcclure Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Racine, WI
    *bump*

    cPanel.net Support Ticket Number:
     
  3. bmcclure

    bmcclure Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Racine, WI
    I think CPanel might use a command-lin -based way of starting Pure-FTPD instead of using the conf file. I need this as well. My customer uses moveable type and has abotu 4,000 files in her archives directory. I don't want to go back to ProFTP though...

    cPanel.net Support Ticket Number:
     
  4. bmcpanel

    bmcpanel Well-Known Member

    Joined:
    Jun 1, 2002
    Messages:
    546
    Likes Received:
    0
    Trophy Points:
    16
    I also attempted to edit the .conf file to change the number of concurrent users allowed, and it did not change. I would also like to know how to edit PureFtp settings. This is important.

    cPanel.net Support Ticket Number:
     
  5. Annette

    Annette Well-Known Member
    PartnerNOC

    Joined:
    Aug 12, 2001
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    16
    In /etc/pure-ftpd.conf, find this:

    # 'ls' recursion limits. The first argument is the maximum number of
    # files to be displayed. The second one is the max subdirectories depth

    LimitRecursion 2000 8

    Set the limits to whatever depth you feel is necessary. Save it, chattr the file, restart pure-ftp.

    cPanel.net Support Ticket Number:
     
  6. bmcclure

    bmcclure Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Racine, WI
    I've tried everything you mentioned (as I said above) except the chattr thing. I'm not familiar with it. What attributes do I want to give the file? Thanks.

    cPanel.net Support Ticket Number:
     
  7. Annette

    Annette Well-Known Member
    PartnerNOC

    Joined:
    Aug 12, 2001
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    16
    chattr +i so the updates don't change it back to the default of 2000 8 as above. We have one set at 20000 8 for a user on one server, since he has about 12000 in a single directory, with more every day, and it works well.

    cPanel.net Support Ticket Number:
     
  8. bmcclure

    bmcclure Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Racine, WI
    still truncates to 2000. I have it set in the file to 20000 10. I did the "chattr +i pure-ftpd.conf" and "service pure-ftpd restart" and it still truncates to 2000. Any other ideas?

    cPanel.net Support Ticket Number:
     
  9. Sash

    Sash Well-Known Member

    Joined:
    Feb 18, 2003
    Messages:
    252
    Likes Received:
    0
    Trophy Points:
    16
    The file to edit is /etc/sysconfig/pure-ftpd . The option you want to edit is "--limitrecursion", located at the bottom. Make sure to restart pureftpd after the change.

    Mike

    cPanel.net Support Ticket Number:
     
  10. Annette

    Annette Well-Known Member
    PartnerNOC

    Joined:
    Aug 12, 2001
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    16
    Interesting. We didn't touch anything other than the file in /etc and all is well - although we've made a couple of modifications that might negate normal use. One of the vagaries we have to live with, I suppose. Whatever works to close out another ticket can't be anything other than good, IMO.

    cPanel.net Support Ticket Number:
     
    #10 Annette, Jun 4, 2003
    Last edited: Jun 4, 2003
  11. goodmove

    goodmove Well-Known Member

    Joined:
    May 12, 2003
    Messages:
    624
    Likes Received:
    0
    Trophy Points:
    16
    Annette, how did you set that for a single user? Is the conf file not server wide?
     
  12. Annette

    Annette Well-Known Member
    PartnerNOC

    Joined:
    Aug 12, 2001
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    16
    No, that's for all users on the same server (and only that server, as we've not changed the defaults on any of the others). That one client just happens to be the only one who has ever needed to list so many files, so we blame it on him. :)

    cPanel.net Support Ticket Number:
     
  13. bmcclure

    bmcclure Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Racine, WI
    Odd, limitrecursion, recursion, or th enumber 2000 aren't found anywhere in that file /etc/sysconfig/pure-ftpd.

    Should I add it?

    cPanel.net Support Ticket Number:
     
  14. Annette

    Annette Well-Known Member
    PartnerNOC

    Joined:
    Aug 12, 2001
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    16
    You can add it, yes. The long item format is:

    --limitrecursion=xxxx:yyyy

    Where xxxx is the max number of files per listing and yyyy is the max directory depth.

    cPanel.net Support Ticket Number:
     
  15. zye

    zye Well-Known Member

    Joined:
    Dec 6, 2002
    Messages:
    96
    Likes Received:
    1
    Trophy Points:
    8
    Pireftpd - FXP

    How do i enable FXP on Pureftpd ?

    I need it urgent.

    Thx in advance
    ZYE

    cPanel.net Support Ticket Number:
     
  16. carlgm

    carlgm Well-Known Member

    Joined:
    Mar 25, 2003
    Messages:
    103
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    England, UK
    Pure-ftpd needs to be updated.

    cPanel.net Support Ticket Number:
     
  17. infinityws

    infinityws Well-Known Member

    Joined:
    Feb 20, 2003
    Messages:
    110
    Likes Received:
    0
    Trophy Points:
    16
    I did this

    --limitrecursion=40000:8

    but it still limits to 2000 files :/
     
  18. jackal

    jackal Well-Known Member
    PartnerNOC

    Joined:
    Feb 23, 2002
    Messages:
    708
    Likes Received:
    0
    Trophy Points:
    16
    ok in /etc/pure-ftpd.conf
    we have this set
    LimitRecursion 40000 12


    In /etc/sysconfig/pure-ftpd we have added this file.

    --LimitRecursion=40000:12

    Then we chattr'ed both files and did a ftp restart in whm under restart services. We are still only showing 2000 files any ideas here?
     
  19. nickn

    nickn Well-Known Member
    PartnerNOC

    Joined:
    Jun 15, 2003
    Messages:
    619
    Likes Received:
    1
    Trophy Points:
    18
    I have mine set exactly as you do, and 4000 works fine.

    Did you restart PureFTPd afterwards, making sure all pureftpd processes were dead before restarting?
     
  20. jackal

    jackal Well-Known Member
    PartnerNOC

    Joined:
    Feb 23, 2002
    Messages:
    708
    Likes Received:
    0
    Trophy Points:
    16
    Well Maybe I am not starting and stopping it correctly and killing processes, Give me a example fo how you would do this to see if I am doing it the same way.
     
Loading...

Share This Page