The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Pure-ftpd umask not being set correctly

Discussion in 'General Discussion' started by Vliegtuig, Feb 10, 2010.

  1. Vliegtuig

    Vliegtuig Well-Known Member

    Joined:
    Jan 21, 2010
    Messages:
    74
    Likes Received:
    2
    Trophy Points:
    6
    Hi everyone,

    It seems the pure-ftpd umask setting is not being handled correctly, which causes SuPHP to trip over my default file permissions.

    umask setting in /etc/pure-ftpd.conf:

    Code:
    Umask 133:022
    Startup script output:

    Code:
    Starting pure-config.pl: Running: /usr/sbin/pure-ftpd -O clf:/var/log/xferlog --daemonize -A -c50 -B -C8 -D -E -fftp -H -I15 -lextauth:/var/run/ftpd.sock -L10000:8 -m4 -s -U133:022 -u100 -i -Oxferlog:/usr/local/apache/domlogs/ftpxferlog -k99 -Z -Y1 -JHIGH:MEDIUM:+TLSv1:!SSLv2:+SSLv3
    
    In the above configuration, I would expect files to have 0744 and directories to have 0755, but they are being set as 666 and 777.

    Any ideas what is going wrong here?
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    What are your settings here in WHM for PHP Handler?
    Main >> Service Configuration >> Apache Configuration >> PHP and SuExec Configuration
     
  3. Vliegtuig

    Vliegtuig Well-Known Member

    Joined:
    Jan 21, 2010
    Messages:
    74
    Likes Received:
    2
    Trophy Points:
    6
    I am handling PHP5 by SuPHP.

    The problem is not a SuPHP one; newly created files through FTP get the wrong umasks.
     
Loading...

Share This Page