The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Pure-ftpd UTF8 issues

Discussion in 'General Discussion' started by pla, Jun 7, 2013.

  1. pla

    pla Member

    Oct 26, 2012
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator

    I have pure-ftpd running on the most recent cpanel under CentOS 5.9. A check with rpm shows pure-ftpd is the latest available from cp: version 1.0.36; release 6.cp1136.

    I telnet to the server on port 21 and issue FEAT. Back comes a list of features but UTF8 is not amongst them.

    I try the same thing with my workstation. Rpm shows the version to be version 1.0.30; release 1.el6 (it came from EPEL) under CentOS 6.4. Telnet to port 21, issue FEAT, get a list of features including UTF8.

    If I use an ftp client such as command-line ftp it can upload and download files with UTF8 names from both servers. I understand this is a client-side decision to display in utf-8 regardless of whether or not the server lists UTF8 as a feature. Other clients are more picky.

    Of the files with utf-8 names on my desktop ls displays the names correctly. On the server ls shows them in a hybridized form using octal escape sequences for non-ASCII characters. Obviously ls got smarter between 5.9 and 6.4.

    So is the behaviour of pure-ftpd on my server down to a mistake when cpanel rebuilt the rpm to their own specs or pure-ftpd's own assumptions about utf-8 filenames on CentOS 5.9? The only 5.9 machines I have access to are production machines so I'm reluctant to experiment and break things. Not even explicitly setting utf-8 in the pure-ftpd config.

    Anybody know the answer?

  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Apr 11, 2011
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    Hello :)

    The cPanel RPM for Pure-FTPd should support UTF-8 by default as far as I am aware. If this is not the case, please open a support ticket so we can investigate:

    Submit A Ticket

    You can post the ticket number here so we can track the issue.

    Thank you.

Share This Page