Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

PureFTP - failed

Discussion in 'General Discussion' started by Antoine Bourlart, Apr 14, 2016.

  1. Antoine Bourlart

    Antoine Bourlart Registered

    Joined:
    Apr 14, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    France
    cPanel Access Level:
    Root Administrator
    Hello,

    When i tried to restarting FTP Server, i've theses errors :
    Apr 14 23:22:21 systemd[1]: Starting Pure-FTPd...
    Apr 14 23:22:21 systemd[1]: Started Pure-FTPd.

    Log Messages
    Apr 14 23:22:21 manager pure-ftpd: (?@?) [ERROR] Unable to start a standalone server: [Address already in use]

    pureftpd has failed. Contact your system administrator if the service does not automagically recover.

    I have csf plugin for the firewall, i've opened IN 30000 to 35000.
    I've tried to uninstall and reinstall an another ftp, i've the same problem.

    I've forget
    lines :
    # PAMAuthentication yes
    # UnixAuthentication yes

    are commented

    and i try
    #CallUploadScript yes
    CallUploadScript yes

    doesn't work

    I've tried too kill with "ps aux|grep ftp" proccess, doesn't work.
    (XID st6maz) The “pureftpd” service failed to start.

    Startup Log
    Apr 14 23:45:16 systemd[1]: Starting Pure-FTPd...
    Apr 14 23:45:16 systemd[1]: Started Pure-FTPd.

    pureftpd has failed. Contact your system administrator if the service does not automagically recover.

    Thank
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,367
    Likes Received:
    1,857
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello :)

    Please try uninstalling and reinstalling Pure-FTPd by first checking to see the name of the pure-ftpd RPM on your system:

    Code:
    rpm -qa|grep pure-ftpd
    Then, remove and reinstall it via the following commands (the package name depends on your system):

    Code:
    rpm -e --nodeps pure-ftpd-1.0.42-3.cp1156.x86_64
    /scripts/check_cpanel_rpms --fix
    Then, ensure you follow the instructions at the following document when making any changes to the configuration file:

    FTP FAQ - Documentation - cPanel Documentation

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    Antoine Bourlart likes this.
  3. Antoine Bourlart

    Antoine Bourlart Registered

    Joined:
    Apr 14, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    France
    cPanel Access Level:
    Root Administrator
    Hi,

    Thank for you response, but i've a problem when i want reinstall it :
    "erreur : le paquet pure-ftpd-1.0.42-3.cp1156.x86_64 n'est pas installé"
    Package is not installed.

    Have you an idea ?

    Thank :)
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,367
    Likes Received:
    1,857
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Did you run the initial command to determine the name of the package on your own system instead of the example?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Antoine Bourlart

    Antoine Bourlart Registered

    Joined:
    Apr 14, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    France
    cPanel Access Level:
    Root Administrator
    Yes sorry, i try it with pure-ftpd-1.0.42-4.cp1154.x86_64
    (with the line command :rpm -qa | grep pure-ftpd)

    I give you a response just after a try
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,367
    Likes Received:
    1,857
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    You can browse to:

    "WHM >> Service Configuration >> FTP Server Selection"

    Check to ensure Pure-FTPd is enabled.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice