The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PureFTP Passive Mode

Discussion in 'General Discussion' started by janus_atw, Dec 21, 2006.

  1. janus_atw

    janus_atw Member

    Joined:
    Sep 17, 2006
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    I'm trying to figure out how to disable "Passive" FTP mode under PureFTP. Since I started using my current server vs. others passive has suddenly become required but since I haven't had to use it in the past I'm sure I can turn it off somehow, I just can't find any document that says how to do it. Thanks for any help anyone can provide me!
     
  2. jayh38

    jayh38 Well-Known Member

    Joined:
    Mar 3, 2006
    Messages:
    1,215
    Likes Received:
    0
    Trophy Points:
    36
    If its enabled, you should have a port range assigned for it in
    /etc/pure-ftpd.conf

    Comment out its value as such:
    #PassivePortRange 35000 36000
     
  3. janus_atw

    janus_atw Member

    Joined:
    Sep 17, 2006
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    That's commented out already, but when I connect to the server with an ftp client I have to tell it to use passive for it to work.
     
  4. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    It makes sense for a connection to port 2083 to be refused for FTP since it is used for cPanel. You may want to check your FTP settings to ensure you are connecting on port 21, not port 2083 (or 2082, 2086, 2087, 2096, 80 or any other port in use)
     
  5. janus_atw

    janus_atw Member

    Joined:
    Sep 17, 2006
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    This is what I get when I try to do a directory listing without switching to passive

    425 Could not open data connection to port 2083: Connection refused
     
  6. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    765
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    N.W. Iowa
    port 2083 is used by Cpanel, so you will not be able to connect thru that port

    Mickalo
     
  7. janus_atw

    janus_atw Member

    Joined:
    Sep 17, 2006
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Then there is something wrong with cpanel, I connect with the default settings of FTP which uses 21, but when I do a LS that's when I get this message, and the port number just increments each time I attempt to list the directory contents. Any ideas why this may be?
     
  8. Billa

    Billa Member

    Joined:
    May 2, 2007
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    #8 Billa, Jul 1, 2007
    Last edited: Jul 1, 2007
  9. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    What you just said above tells me that your FTP client on your home computer
    has not been configured to use "Passive Mode"

    It needs to not only be setup to be allowed on the server but also on
    the FTP program on your own home computer as well!

    It should be noted that passive mode won't work if you have any firewalls on
    either end that block the port ranges used by passive FTP so make sure
    that you have also opened up those ports on your firewall!

    Irregardless whether FTP is in passive or active mode, it uses 2 ports for the connection ....

    Port 21 is the primary listen port used to establish and control the connection.

    In addition, there will be another port number that is used that will be used for any
    actual command processing or data transfers. That secondary port number will be
    different depending on whether you are using passive or active FTP transfers.
    In active FTP transfers, the port would be fixed and the secondary connection
    setup by the server. In passive transfers, a range would be specified for
    watching for the connection and the secondary port connection would be
    established by the client (computer at home).
     
    #9 Spiral, Jul 2, 2007
    Last edited: Jul 2, 2007
  10. ptez

    ptez Active Member

    Joined:
    Jun 5, 2003
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Would like to follow up janus_atw
    since I also encounter this problem.

    How to set default mode as "Passive mode off" ???
     
  11. John Musbach

    John Musbach Registered

    Joined:
    Nov 20, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Here's how to enable passive mode with pureftpd: /http://www.dgunawan.com/28/passivemode follow the steps backwards to disable passive mode, if all else fails you can always ask this question on the pureftpd mailing list here: In order to get help and to share ideas with other users, send a random message to the following address:

    list-subscribe [at] pureftpd.org
     
Loading...

Share This Page