Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED PureFTP Resets Passive Ports & IP Address

Discussion in 'General Discussion' started by Henry Aspden, Dec 18, 2017.

Tags:
  1. Henry Aspden

    Henry Aspden Member

    Joined:
    Nov 2, 2015
    Messages:
    5
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Leeds, UK
    cPanel Access Level:
    Root Administrator
    So I keep going in to change /etc/pure-ftpd.conf and replacing the passive ports and FTP address on lines

    Code:
    PassivePortRange 30000 50000
    
    
    
    # Force an IP address in PASV/EPSV/SPSV replies. - for NAT.
    # Symbolic host names are also accepted for gateways with dynamic IP
    # addresses.
    
    ForcePassiveIP IP.IP.IP.IP(where this is my public IP)
    However, every time I update a pureFTP setting through WHM, this resets itself, also whenever the server does an update this resets itself back to the default...

    Any thoughts on how to change it so that it will always stick to my ports and IP after every update etc? Clearly the preset data is stored somewhere...

    Thanks
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    42,802
    Likes Received:
    1,714
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Henry Aspden likes this.
  3. Henry Aspden

    Henry Aspden Member

    Joined:
    Nov 2, 2015
    Messages:
    5
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Leeds, UK
    cPanel Access Level:
    Root Administrator
    Thanks cPanelMichael that's really helpful !!! I tried searching for this and everyone talks about just updating the pure-ftpd.conf file so I never even thought to check the documentation as I assumed it must not be in there. Thanks so much for your help and sorry for wasting some time here

    Regards

    Henry
     
    cPanelMichael likes this.
Loading...

Share This Page