Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

PuTTY Fatal Error, Network error: Connection timed out

Discussion in 'General Discussion' started by cwuser, Jun 29, 2007.

  1. cwuser

    cwuser Active Member

    Joined:
    Jun 29, 2007
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    51
    Hello,

    I followed a very helpful info from "A Beginner's Guide to Securing Your Server" topic.

    After I installed the firewall and changed the ssh port # from 22 to my choice, I kept disconnected from ssh after a few minutes of idle. However, I was able to log back into ssh.

    So in order to increase the ssh session time out, I modified /etc/ssh/sshd_config (with AllowTcpForwarding YES, ClientAliveInterval 120 and ServerAliveInterval 300) as advised elsewhere in the forum.

    After a minute, I went ahead and rebooted my server via ssh becasue I found the server load became quite high in WHM.

    After the server rebooted, I was able to log back into the WHM and restarted the services, but unfortunately I am NOT able to log into back to ssh anymore. I keep getting “PuTTY Fatal Error, Network error: Connection timed out” error in a little pop up window.

    My server is in data center. I use Linksys router at home but it was never been an issue with using ssh or anything such as VPN to other server and so on.

    I believe this issue caused by my miss modification to sshd_config file. Or, may be something else. I don’t know how to remove all keepalive setting that I put as I mentioned above.

    Did you ever have that similar issue? How did you resolve it?

    Please advise me.


    Thanks.
     
  2. cwuser

    cwuser Active Member

    Joined:
    Jun 29, 2007
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    51
    I just tried ssh again using someone else’ computer but still no lucks. I got errors “PuTTY Fatal Error, Network error: Connection refused

    Is there a way to fix or reinstall sshd_config file that I modified, via WHM. Is there any alternative way to fix this problem?

    Please advise me.


    Thanks.
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,470
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    You can have SSH run up with an empty configuration file (usually on port 22) by browsing to:

    Code:
    http://11.22.33.44:2086/scripts2/doautofixer?autofix=safesshrestart
    If you need to flush iptables, you can also:

    Code:
    http://11.22.33.44:2086/scripts2/doautofixer?autofix=iptablesflush
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. cwuser

    cwuser Active Member

    Joined:
    Jun 29, 2007
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    51
    Thank you for the response.

    I just tried as you advised and I am now able to use ssh but with default port #22 only.

    I still can see my ports configuration settings in conf.apf file (I insall the firewall as I mentioned above posts). However, I am NOT able to use that new ssh port. Do you know why?

    Thanks.
     
  5. cwuser

    cwuser Active Member

    Joined:
    Jun 29, 2007
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    51
    I haven't changed a thing since my last post but I am now UNABLE to ssh to the server again. I have downloaded the whm explorer but don't know how to use it correctly. Do I have to do the iptable flashing again or is there any other alternative way to fix this issue for good?

    Please advise me.

    Thanks.
     
    #5 cwuser, Jun 30, 2007
    Last edited: Jun 30, 2007
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice