Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

python _socket.so error

Discussion in 'General Discussion' started by Dr.Death, Oct 29, 2006.

  1. Dr.Death

    Dr.Death Member

    Joined:
    Oct 10, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    151
    Hi, my cpanel server stoped running , when i run /usr/local/cpanel/startup I get :


    this appear with apachectl and httpd:

    WHM 10.8.0 cPanel 10.9.0-S58
    FreeBSD 6.1-RELEASE i386 - WHM X v3.1.0

    any help plz
     
    #1 Dr.Death, Oct 29, 2006
    Last edited: Oct 29, 2006
  2. krava

    krava Well-Known Member

    Joined:
    Sep 23, 2003
    Messages:
    149
    Likes Received:
    0
    Trophy Points:
    166
    cPanel Access Level:
    Root Administrator
    Hello.

    Did you upgrade MySQL ? Anyway, I advise you to recompile PHP using:
    /script/easyapache

    and upgrade python. It should resolve the issue.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Dr.Death

    Dr.Death Member

    Joined:
    Oct 10, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    151
    Hi Krava,

    yes my cpanel did the upgrade automatic, i run /script/easyapache, but it failed:

    :(
     
  4. krava

    krava Well-Known Member

    Joined:
    Sep 23, 2003
    Messages:
    149
    Likes Received:
    0
    Trophy Points:
    166
    cPanel Access Level:
    Root Administrator
    Check the file:

    /etc/make.conf

    and comment all optimization keys, then update cPanel:
    /script/upcp --force

    and recompile apache/php. Moreover, select php 4.4.4 in easyapche. As I see currently you want to compile php 4.4.3.

    One more thing, did you try to remove the php module from httpd.conf and compile apahce/php using easyapache ?

    Also, look here:

    ****
    Running configure:
    LDFLAGS="-L/usr/X11R6/lib64" /usr/home/cpapachebuild/buildapache/callbacklog --prog configure --dir /usr/home/cpapachebuild/buildapache/build-log -- --with-apxs=/usr/local/apache/bin/apxs --prefix=/usr/local --with-xml --enable-bcmath --enable-calendar --enable-ftp --enable-magic-quotes --with-mysqli --with-mysql=/usr/local --enable-discard-path --with-pear --enable-sockets --enable-track-vars --with-zlib
    ./configure [@php-4.4.3]...(--with-apxs=/usr/local/apache/bin/apxs --prefix=/usr/local --with-xml --enable-bcmath --enable-calendar --enable-ftp --enable-magic-quotes --with-mysqli --with-mysql=/usr/local --enable-discard-path --with-pear --enable-sockets --enable-track-vars --with-zlib)...................Done
    configure: error: mysql configure failed. Please check config.log for more information.
    ****

    Seems you can find what is causign the problem in config.log.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #4 krava, Oct 29, 2006
    Last edited: Oct 29, 2006
  5. Dr.Death

    Dr.Death Member

    Joined:
    Oct 10, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    151
    Hi Krava,

    I did what you suggest, and still the same error. :(

    this is config.log error messages:
    this when run mysql:

    and this is /var/db/mysql/hostname.err :

    thankx
     
    #5 Dr.Death, Oct 30, 2006
    Last edited: Oct 31, 2006
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice