Operating System & Version
cloudlinux7.9
cPanel & WHM Version
94.0.11

Handssler Lopez

Well-Known Member
Apr 30, 2019
65
20
8
Guatemala
cPanel Access Level
Root Administrator
I need help, I have days struggling and I don't know who else to turn to, I can't run this app that uses python, django node and react, this is apparently the last step

[email protected] [/home/user/APP/app]# pip install -r requirements.txt
Requirement already satisfied (use --upgrade to upgrade): amqp==1.4.9 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 1))
Requirement already satisfied (use --upgrade to upgrade): anyjson==0.3.3 in /usr/lib/python2.7/site-packages (from -rrequirements.txt (line 2))
Requirement already satisfied (use --upgrade to upgrade): asn1crypto==0.22.0 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 3))
Requirement already satisfied (use --upgrade to upgrade): billiard==3.3.0.23 in /usr/lib64/python2.7/site-packages (from -r requirements.txt (line 4))
Requirement already satisfied (use --upgrade to upgrade): blessings==1.6 in /usr/lib/python2.7/site-packages (from -rrequirements.txt (line 5))
Requirement already satisfied (use --upgrade to upgrade): bpython==0.16 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 6))
Requirement already satisfied (use --upgrade to upgrade): celery==3.1.25 in /usr/lib/python2.7/site-packages (from -rrequirements.txt (line 7))
Requirement already satisfied (use --upgrade to upgrade): certifi==2017.4.17 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 8))
Requirement already satisfied (use --upgrade to upgrade): cffi==1.10.0 in /usr/lib64/python2.7/site-packages (from -rrequirements.txt (line 9))
Requirement already satisfied (use --upgrade to upgrade): chardet==3.0.4 in /usr/lib/python2.7/site-packages (from -rrequirements.txt (line 10))
Requirement already satisfied (use --upgrade to upgrade): cryptography==2.0 in /usr/lib64/python2.7/site-packages (from -r requirements.txt (line 11))
Requirement already satisfied (use --upgrade to upgrade): curtsies==0.2.11 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 12))
Requirement already satisfied (use --upgrade to upgrade): Django==1.11.3 in /usr/lib/python2.7/site-packages (from -rrequirements.txt (line 13))
Requirement already satisfied (use --upgrade to upgrade): django-celery==3.2.1 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 14))
Requirement already satisfied (use --upgrade to upgrade): django-debug-toolbar==1.8 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 15))
Requirement already satisfied (use --upgrade to upgrade): django-extensions==1.8.1 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 16))
Requirement already satisfied (use --upgrade to upgrade): django-filter==1.0.4 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 17))
Requirement already satisfied (use --upgrade to upgrade): django-render-block==0.5 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 18))
Requirement already satisfied (use --upgrade to upgrade): django-simple-history==1.9.0 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 19))
Requirement already satisfied (use --upgrade to upgrade): django-templated-email==2.1 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 20))
Requirement already satisfied (use --upgrade to upgrade): django-wkhtmltopdf==3.1.0 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 21))
Requirement already satisfied (use --upgrade to upgrade): djangorestframework==3.4.6 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 22))
Requirement already satisfied (use --upgrade to upgrade): enum34==1.1.6 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 23))
Requirement already satisfied (use --upgrade to upgrade): et-xmlfile==1.0.1 in /usr/lib/python2.7/site-packages (from-r requirements.txt (line 24))
Requirement already satisfied (use --upgrade to upgrade): greenlet==0.4.12 in /usr/lib64/python2.7/site-packages (from -r requirements.txt (line 25))
Requirement already satisfied (use --upgrade to upgrade): idna==2.5 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 26))
Requirement already satisfied (use --upgrade to upgrade): ipaddress==1.0.18 in /usr/lib/python2.7/site-packages (from-r requirements.txt (line 27))
Requirement already satisfied (use --upgrade to upgrade): jdcal==1.3 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 28))
Requirement already satisfied (use --upgrade to upgrade): kombu==3.0.37 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 29))
Collecting MySQL-python==1.2.5 (from -r requirements.txt (line 30))
Using cached https://files.pythonhosted.org/pack...5a3a202652828c73453cad/MySQL-python-1.2.5.zip
Collecting mysqlclient==1.3.10 (from -r requirements.txt (line 31))
Using cached https://files.pythonhosted.org/pack...8bac92c60dc855f2523/mysqlclient-1.3.10.tar.gz
Requirement already satisfied (use --upgrade to upgrade): ndg-httpsclient==0.4.2 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 32))
Collecting olefile==0.44 (from -r requirements.txt (line 33))
Using cached https://files.pythonhosted.org/pack...6193114c78e5674df6ef4ac92647/olefile-0.44.zip
Collecting openpyxl==2.4.8 (from -r requirements.txt (line 34))
Using cached https://files.pythonhosted.org/pack...2fd9d4d29f7a8b463808185/openpyxl-2.4.8.tar.gz
Collecting Pillow==4.2.1 (from -r requirements.txt (line 35))
Using cached https://files.pythonhosted.org/pack...illow-4.2.1-cp27-cp27mu-manylinux1_x86_64.whl
Requirement already satisfied (use --upgrade to upgrade): pyasn1==0.2.3 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 36))
Requirement already satisfied (use --upgrade to upgrade): pycparser==2.18 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 37))
Requirement already satisfied (use --upgrade to upgrade): Pygments==2.2.0 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 38))
Requirement already satisfied (use --upgrade to upgrade): pyOpenSSL==17.2.0 in /usr/lib/python2.7/site-packages (from-r requirements.txt (line 39))
Collecting python-dateutil==2.6.1 (from -r requirements.txt (line 40))
Using cached https://files.pythonhosted.org/pack...a2/python_dateutil-2.6.1-py2.py3-none-any.whl
Requirement already satisfied (use --upgrade to upgrade): pytz==2017.2 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 41))
Collecting qrcode==5.3 (from -r requirements.txt (line 42))
Using cached https://files.pythonhosted.org/pack...6f671b52b8344/qrcode-5.3-py2.py3-none-any.whl
Collecting redis==2.10.5 (from -r requirements.txt (line 43))
Using cached https://files.pythonhosted.org/pack...e443ab3d381/redis-2.10.5-py2.py3-none-any.whl
Requirement already satisfied (use --upgrade to upgrade): requests==2.18.2 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 44))
Requirement already satisfied (use --upgrade to upgrade): six==1.10.0 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 45))
Requirement already satisfied (use --upgrade to upgrade): sqlparse==0.2.3 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 46))
Requirement already satisfied (use --upgrade to upgrade): urllib3==1.22 in /usr/lib/python2.7/site-packages (from -r requirements.txt (line 47))
Collecting vine==1.1.4 (from -r requirements.txt (line 48))
Using cached https://files.pythonhosted.org/pack...13c924dabf2a3/vine-1.1.4-py2.py3-none-any.whl
Requirement already satisfied (use --upgrade to upgrade): wcwidth==0.1.7 in /usr/lib/python2.7/site-packages (from -rrequirements.txt (line 49))
Collecting Werkzeug==0.12.2 (from -r requirements.txt (line 50))
Using cached https://files.pythonhosted.org/pack...33d71d1c/Werkzeug-0.12.2-py2.py3-none-any.whl
Installing collected packages: MySQL-python, mysqlclient, olefile, openpyxl, Pillow, python-dateutil, qrcode, redis, vine, Werkzeug
Running setup.py install for MySQL-python ... error
Complete output from command /usr/bin/python2 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-aL0616/MySQL-python/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-CSoN7Z-record/install-record.txt --single-version-externally-managed --compile:
running install
running build
running build_py
creating build
creating build/lib.linux-x86_64-2.7
copying _mysql_exceptions.py -> build/lib.linux-x86_64-2.7
creating build/lib.linux-x86_64-2.7/MySQLdb
copying MySQLdb/__init__.py -> build/lib.linux-x86_64-2.7/MySQLdb
copying MySQLdb/converters.py -> build/lib.linux-x86_64-2.7/MySQLdb
copying MySQLdb/connections.py -> build/lib.linux-x86_64-2.7/MySQLdb
copying MySQLdb/cursors.py -> build/lib.linux-x86_64-2.7/MySQLdb
copying MySQLdb/release.py -> build/lib.linux-x86_64-2.7/MySQLdb
copying MySQLdb/times.py -> build/lib.linux-x86_64-2.7/MySQLdb
creating build/lib.linux-x86_64-2.7/MySQLdb/constants
copying MySQLdb/constants/__init__.py -> build/lib.linux-x86_64-2.7/MySQLdb/constants
copying MySQLdb/constants/CR.py -> build/lib.linux-x86_64-2.7/MySQLdb/constants
copying MySQLdb/constants/FIELD_TYPE.py -> build/lib.linux-x86_64-2.7/MySQLdb/constants
copying MySQLdb/constants/ER.py -> build/lib.linux-x86_64-2.7/MySQLdb/constants
copying MySQLdb/constants/FLAG.py -> build/lib.linux-x86_64-2.7/MySQLdb/constants
copying MySQLdb/constants/REFRESH.py -> build/lib.linux-x86_64-2.7/MySQLdb/constants
copying MySQLdb/constants/CLIENT.py -> build/lib.linux-x86_64-2.7/MySQLdb/constants
running build_ext
building '_mysql' extension
creating build/temp.linux-x86_64-2.7
gcc -pthread -fno-strict-aliasing -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic -D_GNU_SOURCE -fPIC -fwrapv -DNDEBUG -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic -D_GNU_SOURCE -fPIC -fwrapv -fPIC -Dversion_info=(1,2,5,'final',1) -D__version__=1.2.5 -I/usr/include/mysql -I/usr/include/mysql/mysql -I/usr/include/python2.7 -c _mysql.c -o build/temp.linux-x86_64-2.7/_mysql.o
In file included from _mysql.c:44:0:
/usr/include/mysql/my_config.h:3:2: warning: #warning This file should not be included by clients, include only <mysql.h> [-Wcpp]
#warning This file should not be included by clients, include only <mysql.h>
^
_mysql.c: In function ‘_mysql_ConnectionObject_ping’:
_mysql.c:2005:41: error: ‘MYSQL’ has no member named ‘reconnect’
if ( reconnect != -1 ) self->connection.reconnect = reconnect;
^
error: command 'gcc' failed with exit status 1

----------------------------------------
Command "/usr/bin/python2 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-aL0616/MySQL-python/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-CSoN7Z-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-build-aL0616/MySQL-python/
 

cPJustinD

Administrator
Staff member
Jan 12, 2021
286
51
103
Houston
cPanel Access Level
Root Administrator
Hello Handssler Lopez! While I am unfamiliar with the installation, it appears the error begins to occur after this line:
Code:
/usr/include/mysql/my_config.h:3:2: warning: #warning This file should not be included by clients, include only <mysql.h> [-Wcpp]
#warning This file should not be included by clients, include only <mysql.h>
I believe we will likely need to strace the process to determine what is causing the issue here. With that being said, I think it would be best to open a support ticket so that our analysts can review the issue more thoroughly and determine what exactly is occurring. You can submit a support request using the "Submit a ticket" link in my signature below.

Please be sure to link this thread when opening the ticket and provide the ticket number here so that we can track the issue appropriately. If possible, please post the resolution on this thread as it may help other community members with similar issues.
 

Handssler Lopez

Well-Known Member
Apr 30, 2019
65
20
8
Guatemala
cPanel Access Level
Root Administrator
Hello Handssler Lopez! While I am unfamiliar with the installation, it appears the error begins to occur after this line:
Code:
/usr/include/mysql/my_config.h:3:2: warning: #warning This file should not be included by clients, include only <mysql.h> [-Wcpp]
#warning This file should not be included by clients, include only <mysql.h>
I believe we will likely need to strace the process to determine what is causing the issue here. With that being said, I think it would be best to open a support ticket so that our analysts can review the issue more thoroughly and determine what exactly is occurring. You can submit a support request using the "Submit a ticket" link in my signature below.

Please be sure to link this thread when opening the ticket and provide the ticket number here so that we can track the issue appropriately. If possible, please post the resolution on this thread as it may help other community members with similar issues.
Thank you very much @cPJustinD is it possible that you can support me from here without sending a ticket? on one occasion I tried to send a ticket but it sent me to my provider. what happens is that I have hired WHM / cPanel through another company, unfortunately very expensive hourly support, is it possible that they can guide me in the process of how to validate this error?
 

cPJustinD

Administrator
Staff member
Jan 12, 2021
286
51
103
Houston
cPanel Access Level
Root Administrator
As I mentioned earlier, I believe an strace on the process will be the best method to determine what is causing the issue here. Please keep in mind utilizing the strace to diagnose and troubleshoot issues is a task that is best suited for a systems administrator with the skills, training, and expertise required to do so for you.

We do have the following article with more information on utilizing strace that may offer further guidance here:

Basic guide for using strace to diagnose software problems on Linux

Furthermore, we would need access to be able to diagnose the issue on our end, which will require root access. If you do not have root access, you will need to reach out to your hosting provider for further assistance.