The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

question about easyapache 3.26.3

Discussion in 'EasyApache' started by Venomous21, Jul 29, 2014.

  1. Venomous21

    Venomous21 Well-Known Member

    Joined:
    Jun 28, 2012
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    I'm currently running the latest version of php 5.3.x and apache 2.2.x and plan to upgrade to 5.4 once testing is complete. Concerning the latest advisory on cpanel.net for easyapache 3.26.3, if I re-run easy apache, will libxslt & libxml be upgraded to the latest version? It sounds like these are separate from php 5.5. I'm a bit confused and appreciate any info you can provide. Thank you!
     
  2. Shavaun

    Shavaun Well-Known Member

    Joined:
    Aug 15, 2013
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    When you run EasyApache, you can select the version of PHP that you want. Since we still support PHP 5.3, you can run EasyApache without upgrading to PHP 5.4 (until you are ready to upgrade of course). To be certain that you haven't accidentally changed your PHP version, you can double check on the PHP Version stage in EasyApache. You can do this without initiating the build, just don't click the Build button.

    Libxslt and libxml2 will be updated automatically when you run EasyApache, you don't have to make any other changes.
     
  3. cPanelKurtN

    cPanelKurtN Well-Known Member
    Staff Member

    Joined:
    Jan 29, 2013
    Messages:
    95
    Likes Received:
    1
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    As additional verification, you can run the following commands via the command-line before and after running EasyApache so that you can verify version information:

    /opt/xslt/bin/xslt-config --version
    /opt/xml2/bin/xml2-config --version
    /usr/bin/php-cli -v
     
  4. Venomous21

    Venomous21 Well-Known Member

    Joined:
    Jun 28, 2012
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Thank you very much!
     
Loading...

Share This Page