The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

question about new easyapache 3.26.4

Discussion in 'EasyApache' started by Venomous21, Aug 6, 2014.

  1. Venomous21

    Venomous21 Well-Known Member

    Joined:
    Jun 28, 2012
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Hello,

    If I go to our current easy apache build and click customize, mod perl is not selected as an option. Is it safe to ignore this advisory or do I still need to run easy apache because it's patching other related perl modules?

    Thank you!
     
  2. ScottTh

    ScottTh Well-Known Member

    Joined:
    Jan 28, 2013
    Messages:
    157
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Hi Venomous21,

    Are you currently running Apache 2.4?

    mod_perl is only available with Apache 2.2. Here's the link to our mod_perl documentation for some additional information.
     
  3. Venomous21

    Venomous21 Well-Known Member

    Joined:
    Jun 28, 2012
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Hello,

    We are running apache 2.2. Under the options list, I do not have mod perl selected. I reviewed the documentation you provided, thank you. Is it safe to assume I won't need to run easy apache to issue this patch or should I still run it?

    Thank you!
     
  4. Venomous21

    Venomous21 Well-Known Member

    Joined:
    Jun 28, 2012
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    I'd like to upgrade our servers tonight if it's necessary but am hoping it won't be since the mod_perl option isn't selected in easy apache options list. I eagerly await your response. Thank you very much!
     
  5. Shavaun

    Shavaun Well-Known Member

    Joined:
    Aug 15, 2013
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    The mod_perl Apache module is not the same thing as the standard Perl installation that supports your cPanel installation.

    So in other words, unless you have that option selected in EasyApache, the CVE doesn't apply to your configuration and you don't need to worry about it.
     
  6. Venomous21

    Venomous21 Well-Known Member

    Joined:
    Jun 28, 2012
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Thank you very much!
     
Loading...

Share This Page