The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Question about PHP version

Discussion in 'General Discussion' started by Selena, Dec 17, 2011.

  1. Selena

    Selena Active Member

    Joined:
    Jun 22, 2009
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Okay, this may be a dumb question to everyone who knows the answer but I don't and couldn't find an answer to it so here goes...

    I'm using the Release version cpanel and I'm wondering why cpanel is using PHP version 5.2.12 when the current stable version on PHP's website is 5.3.8?

    Second question.. If I were to upgrade to 5.3.8 manually, would this cause any issues with the cpanel software?

    Thank you in advance.
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,451
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
  3. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    If you mean the cPanel/WHM PHP version, then cPanel / WHM uses PHP 5.2.6 as the default rather than PHP 5.3 primarily for Horde compatibility. This differs from the PHP used by accounts and websites that is selected in EasyApache. A discussion of this can be found in this thread:

    http://forums.cpanel.net/f5/backend-php-version-221472.html#post912672

    If you were asking about how to update the cPanel / WHM PHP, this is discussed in both that thread as well as at https://forums.cpanel.net/f5/compiling-cpanel-backend-web-server-php-79309.html#post366633

    If you were instead speaking about the default during EasyApache setup (running /scripts/easyapache or WHM > EasyApache (Apache Update), you may wish to post a feature request concerning having PHP 5.3 as the default instead of PHP 5.2

    Finally, please note you can copy over the profile you have from server to server to have all the options you normally select used on cPanel setup. The profiles are located at /var/cpanel/easy/apache/profile location. You could copy the full profile folder over to the new machine and then run EasyApache to have the same settings compiled.
     
Loading...

Share This Page