Question before upgrade, about php version

bananacy

Member
Mar 26, 2017
17
2
3
depends
cPanel Access Level
Website Owner
Hello,

I realize that at some point i need to upgrade to Easyapache4. I use Wordpress and php5.5 and today noticed a plugin i need requires 5.6.

I run WP on one site (which i suppose supports php7) but i also run a php store that will not work with 7 and never will.

Will i be able to upgrade to Easy4 and run WP with php7 and another site with 5.6 (or 5.5 as now).

Also will upgrading to MariaDb break anything in wordpress?

thanks

/J
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,271
313
Houston
Will i be able to upgrade to Easy4 and run WP with php7 and another site with 5.6 (or 5.5 as now).
Yes, that's the beauty of running EA4 you can have your sites running on different PHP versions.

Also will upgrading to MariaDb break anything in wordpress?
MariaDB is compatible with Wordpress and shouldn't, I would of course as a rule of thumb always make backups before attempting any form of upgrade like this. I would also (personally) do one at a time. Get the EA4 update out of the way first then once you're sure there's no more issues update to MariaDB.


Thanks!