The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Question with autoreply and getting root e-mails

Discussion in 'E-mail Discussions' started by n000b, Jul 13, 2008.

  1. n000b

    n000b Well-Known Member

    Joined:
    Apr 7, 2005
    Messages:
    142
    Likes Received:
    0
    Trophy Points:
    16
    Ok, so I'm the system admin for my server. One of my customers has got an autoreply set on his e-mail account.

    User receives a spam e-mail from a fake e-mail address. His autoresponder replies. My mail server then bounces the message, saying the user doesn't exist. This e-mail comes from Mailer-Daemon@<hostname-of-my-server>. His autoresponder then replies to this again, and I receive this e-mail in my inbox because I have got my e-mail address entered in to the System Mail Preferences page in WHM.

    So two questions here:

    1) Is it possible for Exim to identify a failure/bounce message, and not send out an autorespond to that?
    2) If it isn't possible, how can I change my settings in the System Mail Preferences page in WHM so I don't receive these e-mails, but still receive the important ones? At the moment I've got root and cpanel's mail being forwarded to me with nobody's mail being forward nowhere.

    Thanks :)
     
  2. FreedomBI

    FreedomBI Well-Known Member

    Joined:
    Jul 7, 2008
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    If the autoresponder is responding to Mailer-Daemon, I would consider that a bug.
     
  3. n000b

    n000b Well-Known Member

    Joined:
    Apr 7, 2005
    Messages:
    142
    Likes Received:
    0
    Trophy Points:
    16
    Thanks. Who do I contact about it/how do I confirm that it's a bug? Is there a setting in Exim somewhere that controls this?
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I wouldn't necessarily call it a bug. The SMTP protocol calls for all efforts to deliver an email delivery report to someone if delivery is going to fail.

    The real issue is that auto-responders are arbitrary and respond to any incoming email. This is why, these days, they are an extremely bad idea and using them can end up having the servers IP addresses added to many major RBL's resulting in problems sending out email. I'd suggest having them disabled. It doesn't address the delivery response issue but it does stop your server getting blacklisted.
     
  5. n000b

    n000b Well-Known Member

    Joined:
    Apr 7, 2005
    Messages:
    142
    Likes Received:
    0
    Trophy Points:
    16
    How come I've never noticed this before though chirpy? I've got a lot of users on my server who use autoreponders (I use them myself sometimes too) and I don't think I've ever received replies from autoreponders to mailer-daemon before now...
     
  6. n000b

    n000b Well-Known Member

    Joined:
    Apr 7, 2005
    Messages:
    142
    Likes Received:
    0
    Trophy Points:
    16
    *bump*

    OK I'm now receiving over 30 e-mails a day from autoresponders replying to Mailer Daemon (only from three addresses on my server though) and it's getting really annoying.

    How can I stop receiving e-mails sent to Mailer Daemon while still receiving all the other important e-mails that WHM forwards to me?
     
  7. Michael-MS

    Michael-MS Well-Known Member

    Joined:
    Apr 16, 2003
    Messages:
    144
    Likes Received:
    0
    Trophy Points:
    16
    I have the same problem and found a solution, but haven't tested it yet. So no guarantees that it will work.

    Edit /etc/localaliases (you can also edit in WHM under system mail pref)
    Set root to your email address (should be already)
    Set nobody to a different email address that you don't want to check daily

    Edit /etc/aliases
    Set postmaster to nobody instead of root
    (mail-daemon is set to forward to postmaster so you could change that one instead)
     
  8. n000b

    n000b Well-Known Member

    Joined:
    Apr 7, 2005
    Messages:
    142
    Likes Received:
    0
    Trophy Points:
    16
    Thanks, I'll give it a try :)
     
  9. cPanelCory

    cPanelCory Developer - cPanel Security Team
    Staff Member

    Joined:
    Jan 18, 2008
    Messages:
    69
    Likes Received:
    5
    Trophy Points:
    8
    Location:
    Houston
    cPanel Access Level:
    Root Administrator
    Is the user accepting all email to their default email address for the account, and that address is the one with the auto responder or is this happening regardless of the user setting :fail: in the default address screen ?
     
  10. n000b

    n000b Well-Known Member

    Joined:
    Apr 7, 2005
    Messages:
    142
    Likes Received:
    0
    Trophy Points:
    16
    The default address for the account is set to ":blackhole:".
     
  11. cPanelCory

    cPanelCory Developer - cPanel Security Team
    Staff Member

    Joined:
    Jan 18, 2008
    Messages:
    69
    Likes Received:
    5
    Trophy Points:
    8
    Location:
    Houston
    cPanel Access Level:
    Root Administrator
    I was able to replicate the first email sent from a fake/spoofed domain being responded to, in both :fail: or :blackhole: but I'm not able to get the auto-responder to reply to the Mailer-Daemon email as of yet.

    Can you tell me what build and OS you are running?
     
  12. n000b

    n000b Well-Known Member

    Joined:
    Apr 7, 2005
    Messages:
    142
    Likes Received:
    0
    Trophy Points:
    16
    I've actually just transferred over to a new server and it is still happening.

    The old server was CentOS 5.2 32bit and WHM 11.24.2, and the new one is CentOS 5.3 64bit with WHM 11.24.2.
     
Loading...

Share This Page