Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Questions on Apache 2.4.12 and 5.5.21

Discussion in 'EasyApache' started by vlee, Feb 2, 2015.

  1. vlee

    vlee Well-Known Member

    Joined:
    Oct 13, 2005
    Messages:
    348
    Likes Received:
    23
    Trophy Points:
    168
    Location:
    Spokane, Washington
    cPanel Access Level:
    Root Administrator
    Is it safe and wise to upgrade Apache from Apache 2.2.29 to Apache 2.4.12?

    Or stay using Apache 2.2.29 for now?

    Is it safe and wise to upgrade PHP from PHP 5.4.37 to PHP 5.5.21?

    Or stay using PHP 5.4.37 for now?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. vlee

    vlee Well-Known Member

    Joined:
    Oct 13, 2005
    Messages:
    348
    Likes Received:
    23
    Trophy Points:
    168
    Location:
    Spokane, Washington
    cPanel Access Level:
    Root Administrator
    I forgot to mention that I am running PHP and suEXEC with suPHP
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. JacobPerkins

    JacobPerkins Well-Known Member

    Joined:
    May 2, 2014
    Messages:
    619
    Likes Received:
    96
    Trophy Points:
    103
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Hi vlee,

    When upgrading from Apache 2.2 to 2.4, there are a few syntax changes that you'll need to be aware of, and possible make configuration changes to ensure those directives are compatible:

    http://documentation.cpanel.net/display/EA/Critical+Changes+In+Apache+2.4

    As for upgrading PHP, some web applications might not be compatible with PHP 5.5, so it's best to do research to see what sites you are serving, what applications they are running, and then ensuring compatibility with the new PHP versions.

    I hope this helps!
     
  4. kernow

    kernow Well-Known Member

    Joined:
    Jul 23, 2004
    Messages:
    920
    Likes Received:
    13
    Trophy Points:
    168
    cPanel Access Level:
    Root Administrator
    Of Note, WHMCS will not work with php 5.5
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. vlee

    vlee Well-Known Member

    Joined:
    Oct 13, 2005
    Messages:
    348
    Likes Received:
    23
    Trophy Points:
    168
    Location:
    Spokane, Washington
    cPanel Access Level:
    Root Administrator
    Sounds like I better wait on this then and stay with current configuration.

    I do not use these below in Apache

    mod_perl
    mod_mono
    mod_qos

    I do use mod_deflate though.

    In away I can do Apache 2.4.12 with PHP 5.4.37 am I correct?

    Since PHP 5.5.21 breaks WHMCS.

    Any thoughts from others on this matter?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. JacobPerkins

    JacobPerkins Well-Known Member

    Joined:
    May 2, 2014
    Messages:
    619
    Likes Received:
    96
    Trophy Points:
    103
    cPanel Access Level:
    DataCenter Provider
    Twitter:

    You can setup Apache 2.4 with PHP 5.4, no problem. Just go through EasyApache and set it up as you like :)
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice