Questions Regarding EasyApache: Apache & PHP Executable Types

deth4uall

Well-Known Member
Sep 30, 2011
45
0
56
Austin, Texas, United States
cPanel Access Level
Root Administrator
Okay, so a while back I did research into how I could enable multiple versions of PHP on my cPanel server and found a few answers but I still think that I may have done it wrong by enabling the wrong options. So I am just wanting to know more about the following options and how they affect how the server runs. Please note I used EasyApache to install all of the below so bear with me as I try to piece together how I can improve on this etc and get the right solution.

Apache: Mod FCGID, Mod SuPHP
Other Modules: Mod Sec, Xcache for PHP

I have tried looking online for more information but haven't found any good articles so far and will continue looking, I want to have a caching method but know that suphp doesn't allow that. I think I saw FCGID did but since I have SuPHP installed as well it was not being allowed. I think I may have two totally different types installed but I wanted to see if the community could help out. Thanks!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
Hello :)

Are you attempting to configure multiple versions of PHP 5, or are you only deciding which PHP handler to use? You can find more information about each PHP handler at:

Apache PHP Request Handling

Thank you.