The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

quota problem,help plz!

Discussion in 'General Discussion' started by tshin, May 21, 2005.

  1. tshin

    tshin Active Member

    Joined:
    Dec 14, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    hello,
    i have a big problem.
    my php is working as apache mod.
    so files uploaded/created by php scripts get nobody.nobody.
    then these files are not in the user's quota.
    for example,
    the user's space used shows 50M in WHM.
    he upload a file(10M) by php scripts.
    then also shows 50M in WHM.
    so how can i fix it?

    i dont want to change php working as CGI.
    and i've used /scripts/chownpublichtmils,it cause some php scripts error.
    can i have some other things to do with it?
    thank you veryvery much.
    thank you.

    or

    are there some method i can temply solve the problem?
    i can do the method once a period of time,and next period of time,i do it again.
    can i?

    thank you very much!
     
  2. tshin

    tshin Active Member

    Joined:
    Dec 14, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    please help me..
     
  3. tshin

    tshin Active Member

    Joined:
    Dec 14, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    any ideas?
    thank you~~
     
  4. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    where are u trying to upload the files.. i guess php upload first goes to /tmp ?
     
  5. tshin

    tshin Active Member

    Joined:
    Dec 14, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    thanks.

    no.
    user uploads files in his dir,but the uploaded files are "nobody.nobody"
    so cause the quota not correct..

    thank you.
     
  6. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    try

    Main >> Service Configuration >> Enable/Disable SuExec

    enable suexec and see ?
     
  7. tshin

    tshin Active Member

    Joined:
    Dec 14, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    it's already enabled.
    thank you
     
  8. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    Set up a cron(tab) however often you wish to run the following programs:

    /scripts/chownpublichtmls
    /scripts/enablefileprotect
     
  9. tshin

    tshin Active Member

    Joined:
    Dec 14, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    yes i have done above before.
    and it cause some php scripts problem.

    if i disable SuExec,then do above,maybe it doesn't cause php problems?
     
  10. tshin

    tshin Active Member

    Joined:
    Dec 14, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    can i do something?
    thank you.
    any suggestions plz..
     
  11. tshin

    tshin Active Member

    Joined:
    Dec 14, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    help me please..
    space is reducing day by day..
     
  12. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Haze has already provided you with the answer. If anything breaks after doing that you'll need to investigate and fix it.
     
Loading...

Share This Page