The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Quota problem - Scripts uploading files as 'nobody'

Discussion in 'General Discussion' started by gvard, Oct 13, 2005.

  1. gvard

    gvard Well-Known Member
    PartnerNOC

    Joined:
    Dec 22, 2003
    Messages:
    195
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Athens/GREECE
    cPanel Access Level:
    DataCenter Provider
    Greetings from Greece,

    I searched the forums but didn't find anything (the word 'nobody' is a common word and the search engine didn't include it in the search criteria, so I couldn't do a successful search).

    Some PHP scripts (like galleries) allows the site's visitors to upload files. Those files are uploaded as user 'nobody' and don't count for the user's quota. For example, I've a user with quota 200MB (user1) and in "quota user1" I see that the user uses 100MB but when I go at /home/user1/www and enter "du -sh */" I see an "uploads" directory that has 450MB of files.

    Does anyone know how to fix that "problem" and have everything that PHP scripts under user1 upload count at user1's total disk quota?


    Thank you in advance :)
     
  2. Xenon101

    Xenon101 Well-Known Member

    Joined:
    Mar 13, 2005
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    You could enable PHP Suexec? To do so go to ssh and type /scripts/easyapache. Proceed to option 6 (advanced configuration) there will be a box somewhere there for PHP Suexec, then when any php script runs it will run as the username instead of nobody, this should fix the users uploads (i would presume!)
     
Loading...

Share This Page