The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Quotas not working on Dedicated Server

Discussion in 'General Discussion' started by matt1206, Aug 25, 2015.

  1. matt1206

    matt1206 Member

    Joined:
    Dec 20, 2011
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I've just noticed that quotas aren't working correctly on my dedicated server.

    I've read elsewhere on here that I might been to symlink /dev/md1 to /dev/root

    Code:
    ln -s /dev/md1 /dev/root
    Will this cause any issues with the server?

    Code:
    root@cpanel [/tmp]# cat /etc/fstab
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    /dev/md1        /       ext4    errors=remount-ro,usrjquota=quota.user,jqfmt=vfsv0      0       1
    /dev/sda2       swap    swap    defaults        0       0
    /dev/sdb2       swap    swap    defaults        0       0
    /dev/sdc2       swap    swap    defaults        0       0
    proc            /proc   proc    defaults                0       0
    sysfs           /sys    sysfs   defaults                0       0
    tmpfs           /dev/shm        tmpfs   defaults        0       0
    devpts          /dev/pts        devpts  defaults        0       0
    tmpfs           /var/mysqltmp   tmpfs rw,gid=497,uid=498,size=1024M,nr_inodes=10k,mode=0700 0 0
    Code:
    root@cpanel [/tmp]# ls -l /dev/root
    /bin/ls: cannot access /dev/root: No such file or directory
    root@cpanel [/tmp]# ^C
    root@cpanel [/tmp]# df -h
    Filesystem            Size  Used Avail Use% Mounted on
    rootfs                274G   67G  193G  26% /
    /dev/root             274G   67G  193G  26% /
    devtmpfs               32G  488K   32G   1% /dev
    tmpfs                  32G   12K   32G   1% /dev/shm
    tmpfs                 1.0G  4.0K  1.0G   1% /var/mysqltmp
    /dev/root             274G   67G  193G  26% /var/tmp

    Code:
    root@cpanel [/tmp]# mount
    rootfs on / type rootfs (rw)
    /dev/root on / type ext4 (rw,relatime,errors=remount-ro,data=ordered,jqfmt=vfsv0,usrjquota=quota.user)
    devtmpfs on /dev type devtmpfs (rw,relatime,size=32967188k,nr_inodes=8241797,mode=755)
    none on /proc type proc (rw,relatime)
    none on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
    devpts on /dev/pts type devpts (rw,relatime,mode=600,ptmxmode=000)
    tmpfs on /dev/shm type tmpfs (rw,relatime)
    tmpfs on /var/mysqltmp type tmpfs (rw,relatime,size=1048576k,nr_inodes=10240,mode=700,uid=498,gid=497)
    none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,relatime)
    /dev/root on /var/tmp type ext4 (rw,relatime,errors=remount-ro,data=ordered,jqfmt=vfsv0,usrjquota=quota.user)
    Thanks,
     
  2. matt1206

    matt1206 Member

    Joined:
    Dec 20, 2011
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I ran the ln -s command, and it allowed me to run the fixquotas script.
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,834
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    I'm happy to see the issue is now resolved. Thank you for updating us with the outcome.
     
Loading...

Share This Page