pboulanov

Registered
Jan 9, 2021
3
0
1
Montrael
cPanel Access Level
Root Administrator
At this new install on a dedicated server with CentOS 7.9 and WHM/cPanel 92.0.7 we have the error of
Filesystem quotas are currently disabled.

Going through the 'Click to Enable' doesn't do anything, so I followed this guide How to Fix Quotas and here are my steps + outputs:


fstab:
UUID="bd64be74" / xfs defaults,uquota 0 0
UUID="77842e9c" /boot xfs defaults 0 0
UUID="38b334ca" swap swap defaults 0 0
UUID="7cd6ac9b" swap swap defaults 0 0
LABEL=EFI_SYSPART /boot/efi vfat defaults 0 0
/usr/tmpDSK /tmp ext3 defaults,noauto 0 0


Running
/usr/local/cpanel/scripts/initquotas
Results in
journaled quota support: kernel supports, user space tools supports (available)
checking out /backup
Warning : Your system does not have a separate filesystem for backups. This may cause performance degradation during the backup process.
UUID="bd64be74" (already configured quotas = 1).
UUID="77842e9c" (already configured quotas = 0).
Updating Quota Files..........Done
Quotas have been enabled and updated.


The step which I need to check gives me 'no files available'

[[email protected] /]# ls -l /*.user
ls: cannot access /*.user: No such file or directory


I have opened a ticket with cPanel and they have not figured it out, sending me to my IAAS provider. They sent me back to cPanel as they only provide the metal.

Here I am!
 
Last edited:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
2,977
376
213
cPanel Access Level
Root Administrator
Hey there! As the cPanel techs previously mentioned, the quotas aren't something that are handled by cPanel but by the operating system itself. To ensure quotas are working properly on the OS itself, you may want to check this article here:


Can you try that and see if that helps get things working?
 

pboulanov

Registered
Jan 9, 2021
3
0
1
Montrael
cPanel Access Level
Root Administrator
No luck on this process.

[[email protected] ~]# grep xfs /etc/fstab
UUID="bd64be74" / xfs defaults,uquota 0 0
UUID="77842e9c" /boot xfs defaults 0 0
[[email protected] ~]# mount | grep xfs | grep -v virtfs
/dev/md3 on / type xfs (rw,relatime,attr2,inode64,noquota)
/dev/md2 on /boot type xfs (rw,relatime,attr2,inode64,noquota)
[[email protected] ~]# /scripts/initquotas
journaled quota support: kernel supports, user space tools supports (available)
checking out /backup
Warning : Your system does not have a separate filesystem for backups. This may cause performance degradation during the backup process.
UUID="bd64be74" (already configured quotas = 1).
UUID="77842e9c" (already configured quotas = 0).
Updating Quota Files..........Done
Quotas have been enabled and updated.
[[email protected] ~]# /scripts/fixquotas
journaled quota support: kernel supports, user space tools supports (available)
checking out /backup
Warning : Your system does not have a separate filesystem for backups. This may cause performance degradation during the backup process.
UUID="bd64be74" (already configured quotas = 1).
UUID="77842e9c" (already configured quotas = 0).
Updating Quota Files..........Done
Quotas have been enabled and updated.
You must reboot the server to enable XFS® filesystem quotas.


After a reboot, the message stays and things don't settle.
Updated to v92.0.9 since the first post.


[[email protected] ~]# grep xfs /etc/fstab
UUID="bd64be74-f1cd" / xfs defaults,uquota 0 0
UUID="77842e9c" /boot xfs defaults 0 0
[[email protected] ~]# mount | grep xfs | grep -v virtfs
/dev/md3 on / type xfs (rw,relatime,attr2,inode64,noquota)
/dev/md2 on /boot type xfs (rw,relatime,attr2,inode64,noquota)


Following this guide doesn't do anything either.

If I'm looking at the file /etc/sysconfig/grub
I did make sure that it looks great.
GRUB_CMDLINE_LINUX="rd.auto crashkernel=auto vga=normal nomodeset rootflags=uquota"
 
Last edited:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
2,977
376
213
cPanel Access Level
Root Administrator
Could you submit a ticket to our support team so we could take a look at this? That way we'd be able to confirm if this was an OS issue or an issue with cPanel on the system. IF you do get a ticket opened could you post the number here so I can follow along and keep this thread updated?
 

cPAdminsMichael

Well-Known Member
Dec 19, 2016
141
45
103
Denmark
cPanel Access Level
Root Administrator
This is usually a Grub configuration issue. I'd need to see your grub.cfg to check it, but else usually reconfiguring Grub configuration will fix your issue:
Code:
cp -p /boot/grub2/grub.cfg /boot/grub2/grub.cfg.orig
grub2-mkconfig -o /boot/grub2/grub.cfg
... and reboot.
 
  • Like
Reactions: cPRex

pboulanov

Registered
Jan 9, 2021
3
0
1
Montrael
cPanel Access Level
Root Administrator
Could you submit a ticket to our support team so we could take a look at this? That way we'd be able to confirm if this was an OS issue or an issue with cPanel on the system. IF you do get a ticket opened could you post the number here so I can follow along and keep this thread updated?
Sure - last time I was sent back to my host provider, but they only provide metal. Ticket 94007776

This is usually a Grub configuration issue. I'd need to see your grub.cfg to check it, but else usually reconfiguring Grub configuration will fix your issue:
Code:
cp -p /boot/grub2/grub.cfg /boot/grub2/grub.cfg.orig
grub2-mkconfig -o /boot/grub2/grub.cfg
... and reboot.
Did that - no effect.
Do you want me to parse the grub config file here?
 

cPAdminsMichael

Well-Known Member
Dec 19, 2016
141
45
103
Denmark
cPanel Access Level
Root Administrator
Hmm - there must be something in your Grub configuration or maybe kernel that doesn't include quota.
You are welcome to share your grub.cfg and I'll have a quick look.