The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Quotas turn on

Discussion in 'Data Protection' started by Freedoom, Dec 16, 2005.

  1. Freedoom

    Freedoom Member

    Joined:
    Dec 12, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Hello. How can i turn the quotas on ? in the initial quotas when i try to enable quotas ive a message to turn the quotas on, but i dont know the comand to do this.

    regards,
     
  2. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    /scripts/initquotas should turn it on.
     
  3. Freedoom

    Freedoom Member

    Joined:
    Dec 12, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Code:
    !! No Filesystems are mounted with quota support !!
    
    Under freebsd you must edit /etc/fstab and turn on quotas.
    Note: make sure your kernel supports quotas before doing this.
    After you have remounted your file systems with quota support,
    re-run this script.
    when i try to edit the file fstab it says i have no permission and im loged has su admin, how can i edit the file ?
     
  4. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    You have to be root to edit it...
     
  5. aress

    aress Active Member

    Joined:
    May 5, 2004
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    6
    Quota On

    This should also do
    quotaoff /home
    quotacheck -c /home
    quotacheck -mc /home
    quotaon /home
    but you need to be a root user for it.
     
  6. Freedoom

    Freedoom Member

    Joined:
    Dec 12, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Im using this tutorial but i cant see any date in cd /usr/src ee UPDATING
    :S

    Code:
    Quick and Dirty How to compile 'QUOTA' support for your FreeBSD server.
    
    Please see: http://www.freebsd.org/doc/en_US.ISO...ok/quotas.html for more detailed instructions.
    
    To complete the following you will need to have to ssh access to your host server along with full root access.
    
    Login to the remote host via SSH and become root with 'su -' then backup your current kernel and '/etc' directory.
    
    cp -Rp /boot/kernel /boot/kernel.good
    cp -Rp /etc /etc.good
    
    Now verify you have the correct source code for your server installed in '/usr/src'
    cd /usr/src
    ee UPDATING
    
    Make sure the first displayed date matches your current 'uname -a' output.
    
    Once you have confirmed you have the correct source code installed you can then create your custom kernel configuration file.
    
    cd /usr/src/sys/i386/conf
    cp GENERIC MYKERNELCONF
    ee MYKERNELCONF
    
    
    Add the line below to your kernel configuration file and then save the file.
    
    ## Example Entry for your Kernel Conf ##
    
    options QUOTA # Provide Quota Support
    
    ##
    
    Next you will need to build and install your custom kernel.( This step could take a few mins )
    
    cd /usr/src/
    make buildkernel KERNCONF=MYKERNCONF
    make installkernel KERNCONF=MYKERNCONF
    
    Now before you reboot you need to edit 2 files to enable QOUTA support for you file system.
    
    The first is the '/etc/rc.conf' which will we will edit to enable QUOTA support and to also check them on boot.
    
    grep /etc/defaults/quota >> /etc/rc.conf
    ee /etc/rc.conf
    
    You will see the following entries at the bottom of the '/etc/rc.conf' file.
    
    enable_quotas="NO" # turn on quotas on startup (or NO).
    check_quotas="YES" # Check quotas on startup (or NO).
    
    Change both of the entries to "YES" and then save the file.
    
    enable_quotas="YES" # turn on quotas on startup (or NO).
    check_quotas="YES" # Check quotas on startup (or NO).
    
    Now you need to modify your '/etc/fstab' file to select which slices should have QUOTAS turned on.
    
    Typical '/etc/fstab' file with NO quota support enabled.
    
    # Device Mountpoint FStype Options Dump Pass#
    /dev/ad0s1b none swap sw 0 0
    /dev/ad0s1a / ufs rw 1 1
    /dev/ad0s1f /home ufs rw 2 2
    /dev/ad0s1e /usr ufs rw 2 2
    /dev/ad0s1d /var ufs rw 2 2
    
    Typical '/etc/fstab' with quota support enabled.
    
    # Device Mountpoint FStype Options Dump Pass#
    /dev/ad0s1b none swap sw 0 0
    /dev/ad0s1a / ufs rw 1 1
    /dev/ad0s1f /home ufs rw,userquota,groupquota 2 2
    /dev/ad0s1e /usr ufs rw,userquota,groupquota 2 2
    /dev/ad0s1d /var ufs rw 2 2
    
    Now save the '/etc/fstab' file and reboot the host to load the new kernel and remount your drives with full quota support enabled for your server.
    
    reboot
    
    
    If for some reason your server does not come back up after 2-10 mins from the reboot please contact our support team and let them know you just compiled a custom kernel and may need to have the server booted with the old backup kernel you made earlier. If the server reboots with no problems you should be all set and ready to go with full quota support for your control panel of choice.
     
  7. ShockHosts

    ShockHosts Well-Known Member

    Joined:
    Nov 25, 2005
    Messages:
    123
    Likes Received:
    0
    Trophy Points:
    16
    Just out of curiosity, what 'quotas' are you referring to?
     
  8. Freedoom

    Freedoom Member

    Joined:
    Dec 12, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Quotas in whm and the space used arent showing, it appears unlimited quotas and 0 space used :mad:
     
  9. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    Did you compile your kernal with quotas enabled?
     
  10. Freedoom

    Freedoom Member

    Joined:
    Dec 12, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    no but im trying to do that, but first i need to confirme this
    Code:
    Now verify you have the correct source code for your server installed in '/usr/src'
      cd /usr/src
      ee UPDATING
     
      Make sure the first displayed date matches your current 'uname -a' output.
    
     
  11. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    what do you see in

    /usr/src/sys/i386/conf ?
     
  12. ShockHosts

    ShockHosts Well-Known Member

    Joined:
    Nov 25, 2005
    Messages:
    123
    Likes Received:
    0
    Trophy Points:
    16
    Try reinstalling cPanel.
     
  13. Freedoom

    Freedoom Member

    Joined:
    Dec 12, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    nothing :( it says:
    Code:
    webhosting# /usr/src/sys/i386/conf
    /usr/src/sys/i386/conf: Permission denied.
     
  14. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    Your logged in as root or su right?

    cd /usr/src/sys/i386/conf

    then type ls -a

    and paste the results.
     
  15. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    easyhoster1 is right. You can't do that with FreeBSD. Your kernel must be re-compiled with quotas, first.
     
Loading...

Share This Page