The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

R=virtual_aliases: This address no longer accepts mail

Discussion in 'E-mail Discussions' started by dbrookeJP, Nov 23, 2016.

  1. dbrookeJP

    dbrookeJP Member

    Joined:
    Aug 24, 2016
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Wisconsin
    cPanel Access Level:
    Root Administrator
    Hello,
    cPanel 54.0.29
    PHP 5.6.24

    Hello, I have set up a website / account (codeigniter 3 / PHP). The website has a login that is supposed to send email to our remote SMTP server for relaying. It's not working from this account... looks like it's being blocked by cPanel. We do have another account with a forum that uses the same information (host, port) and that works fine (though it took tweaking the exim settings).

    The full error is:
    Code:
    exim_mainlog:183311:2016-11-22 15:25:03 1c9Hcl-0004aO-HT <= webmaster@example.com U=saadmin P=local S=782 id=5834a99f75f55@example.com T="Sunshine Artist Email Test" for donovanb@example.com
    exim_mainlog:183313:2016-11-22 15:25:03 1c9Hcl-0004aO-HT ** donovanb@example.com R=virtual_aliases: This address no longer accepts mail."
    

    I have read stuff online including:
    Why didn't my email get delivered? or where did my email go?

    But haven't been able to find my exact solution.

    It appears that the cPanel server thinks there is a local mailbox for donovanb???. The cPanel server *IS* DNS for example.com, but the MX records will point to an external mail server.

    Another note, the donovanb@example.com address is the contact info for that cPanel account.. wasn't sure if that created some problems??

    Thanks for your guidance... have been beating my head against the wall for a couple days now.

    Donovan
     
    #1 dbrookeJP, Nov 23, 2016
    Last edited by a moderator: Nov 23, 2016
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,064
    Likes Received:
    1,287
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Browse to "WHM >> DNS Functions >> Edit DNS Zone" and verify the email routing settings for this domain name are set to "Remote Mail Exchanger".

    Thank you.
     
  3. dbrookeJP

    dbrookeJP Member

    Joined:
    Aug 24, 2016
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Wisconsin
    cPanel Access Level:
    Root Administrator
    Hi Michael, I did check that setting, and it was set to local. I changed it to remote, but no difference.

    I have also changed a few other things now that I don't clearly understand :).. but still basically the same error.

    I have since told Exim to send mail as the accounts IP address.
    And have since added an spf record for that IP address.

    Still the same result, but now the exim_mainlog does not get an error. The output of the debugger for PHP is as follows:
    Code:
    220 mail.example.com Microsoft ESMTP MAIL Service ready at Wed, 23 Nov 2016 17:58:03 -0600
    
    Code:
    hello: 250-mail.example.com Hello [64.131.68. xxx]
    250-SIZE 51445760
    250-PIPELINING
    250-DSN
    250-ENHANCEDSTATUSCODES
    250-STARTTLS
    250-AUTH
    250-8BITMIME
    250-BINARYMIME
    250 CHUNKING
    
    Code:
    Failed to send AUTH LOGIN command. Error:
    Unable to send email using PHP SMTP. Your server might not be configured to send mail using this method.
    
    Code:
    User-Agent: CodeIgniter
    Date: Wed, 23 Nov 2016 23:58:04 +0000
    From: " Admin" <webmaster@example.com>
    Return-Path: <webmaster@example.com>
    To: someusr@domain.us
    Subject: =?ISO-8859-1?Q?=53=75=6E=73=68=69=6E=65=20=41=72=74=69=73=74=20=45=6D=61?= =?ISO-8859-1?Q?=69=6C=20=54=65=73=74?=
    Reply-To: <webmaster@example.com>
    X-Sender: webmaster@example.com
    X-Mailer: CodeIgniter
    X-Priority: 3 (Normal)
    Message-ID: <58362d0c805bb@example.com>
    Mime-Version: 1.0
    
    
    Content-Type: text/plain; charset=ISO-8859-1
    Content-Transfer-Encoding: 8bit
    
    Testing the email class.
    
    
    Looks to me like the mail server is getting a hit, then can't authenticate??

    Thx.
     
    #3 dbrookeJP, Nov 23, 2016
    Last edited by a moderator: Nov 23, 2016
  4. dbrookeJP

    dbrookeJP Member

    Joined:
    Aug 24, 2016
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Wisconsin
    cPanel Access Level:
    Root Administrator
    Updating this: "Can't Authenticate" finally led me in the right direction. The external mail server wasn't listening for SMTP at all. Solved! :-/
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,064
    Likes Received:
    1,287
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    I'm happy to see you were able to resolve the issue. Thank you for updating us with the outcome.
     
Loading...

Share This Page