The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Raise FD_SETSIZE

Discussion in 'General Discussion' started by Cristi4n, Mar 7, 2009.

  1. Cristi4n

    Cristi4n Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2006
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    Hello everyone,

    I tried a lot of things to get rid of the errors:

    socket.c:2184: REQUIRE(maxfd <= (int)1024) failed.
    host: isc_socket_create: not enough free resources

    but nothing seems to work ok/raise the max file descriptors.
    I have tried to:

    modify /usr/include/bits/typesizes.h & recompile with easyapache
    modify the default template and set the RaiseFD.. option to 1 & recompile with easyapache
    dome other small things found on the internet but nothing was ok.

    Can anyone help me on this issue please ?
     
  2. Cristi4n

    Cristi4n Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2006
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    I know this does not have a simple solution, but I would like to know a few ideas about how to solve my problem.
    I even added CFLAGS to cPanel and recompiled apache and php with easy apache but still no luck.
    Something else is still on the 1024 limit and I cannot find out exactly what. I recompiled openssl and curl also and no result either.
    If anyone has other ideas please help.
     
  3. Cristi4n

    Cristi4n Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2006
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    I guess a "recompile the bind-utils stupid" would have beed a great answer.
    Problem solved.
     

Share This Page