Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

raising the MaxRequestWorkers

Discussion in 'Workarounds and Optimization' started by dzamanakos, Jun 21, 2016.

  1. dzamanakos

    dzamanakos Active Member

    Joined:
    Feb 15, 2014
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Hi, just got this message in my apache log :
    [mpm_worker:error] [pid 13825:tid 139805119400000] AH00287: server is within MinSpareThreads of MaxRequestWorkers, consider raising the MaxRequestWorkers setting

    I'm using the defaults (Server Limit, Max Request Workers etc) in apache configuration.

    Should i raise the MaxRequestWorkers only, or the Server Limit too?

    My system uses 32gb of ram, about 20-25gb is buff/cached right now, mysql is set with :
    [OK] Maximum reached memory usage: 9.6G (30.60% of installed RAM)
    [OK] Maximum possible memory usage: 19.9G (63.57% of installed RAM)


    Thank you,
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,435
    Likes Received:
    1,961
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    You can browse to "WHM » Service Configuration » Apache Configuration » Global Configuration" in order to increase the "Max Request Workers" limit. Per it's description, this directive sets the limit on the number of simultaneous requests that will be served. This interface allows up to the value of the ServerLimit setting, thus you must also increase the ServerLimit setting so it's at least the same value as the "Max Request Workers" limit.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. kdean

    kdean Well-Known Member

    Joined:
    Oct 19, 2012
    Messages:
    290
    Likes Received:
    21
    Trophy Points:
    18
    Location:
    Orlando, FL
    cPanel Access Level:
    Root Administrator
    Actually for Worker and Event MPMs, MaxRequestWorkers can and should Exceed the ServerLimit because in those configurations MaxRequestWorkers is measured in threads and ServerLimit is processes where ServerLimit x ThreadsPerChild = MaxRequestWorkers. The Global Configuration interface only calculates correctly for Prefork and just gets in the way when doing Worker and Event due to it's incorrect requirement of the serverlimit.

    I detailed more about this and how to workaround it in this post:

    Using 'Global Configuration' for MPM Worker

    There was talk about needing a feature request for this, but it's really a bug that should be fixed. For some reason it's never acknowledged.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice