Randomly Myql wont detect innodb

bhanuprasad1981

Well-Known Member
Aug 5, 2008
222
0
66
India
past some days suddenly mysql stops detecting innodb i am left with message :-

Unknown table engine ‘InnoDB’‏


repeated restarts of mysql brings back the normal stage, what is this error cause and any good solution


here are some details :=

mysql Server version: 5.5.22-cll MySQL Community Server (GPL)
WHM 11.32.2 (build 27)


etc/my.cnf:-

Code:
[mysqld]
datadir=/home/var/lib/mysql
socket=/home/var/lib/mysql/mysql.sock
tmpdir=/dev/shm
user=mysql
sql-mode = NO_ENGINE_SUBSTITUTION
back_log = 50
local-infile=0
#skip-innodb
#innodb=OFF
max_connections = 150
max_user_connections=30
key_buffer_size = 800M
myisam_sort_buffer_size = 64M
myisam_max_sort_file_size = 2048M
join_buffer_size = 2048K
read_buffer_size = 512K
sort_buffer_size = 512K
table_definition_cache = 10000
table_open_cache = 10000
thread_cache_size = 384
wait_timeout = 30
interactive_timeout = 30
connect_timeout = 10
tmp_table_size = 384M
max_heap_table_size = 384M
max_allowed_packet = 64M
max_seeks_for_key = 1000
group_concat_max_len = 1024
max_length_for_sort_data = 1024
net_buffer_length = 16384
max_connect_errors = 100000
concurrent_insert = ALWAYS 
read_rnd_buffer_size = 256K
bulk_insert_buffer_size = 8M
query_cache_limit = 1024K
query_cache_size = 128M
query_cache_type = 1
query_prealloc_size = 262144
query_alloc_block_size = 65536
range_alloc_block_size = 4096
transaction_alloc_block_size = 8192
transaction_prealloc_size = 4096
default-storage-engine = MyISAM
max_write_lock_count = 1


innodb_buffer_pool_instances=1
innodb_flush_method = O_DIRECT
innodb_adaptive_flushing = 1
innodb_purge_threads=1

# innodb settings
innodb_file_per_table = 1
innodb_open_files = 500
innodb_data_file_path= ibdata1:10M:autoextend
innodb_buffer_pool_size = 20G
innodb_additional_mem_pool_size = 32M

innodb_log_files_in_group = 2
innodb_log_file_size = 5M
innodb_log_buffer_size = 8M
innodb_flush_log_at_trx_commit = 2
innodb_thread_concurrency = 8
innodb_lock_wait_timeout=30

innodb_io_capacity = 200
innodb_read_io_threads = 2
innodb_write_io_threads = 2

long_query_time=1
#slow_query_log=1
#slow_query_log_file=/var/log/mysql/slowq.log

[mysqld_safe]
#log-error=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid
nice = -5
open-files-limit = 8192

[mysqldump]
quick
max_allowed_packet = 64M

[myisamchk]
key_buffer_size = 1024M
sort_buffer_size = 1M
read_buffer_size = 1M
write_buffer_size = 1M

[mysqlhotcopy]
interactive-timeout
 

bhanuprasad1981

Well-Known Member
Aug 5, 2008
222
0
66
India
on that day issue happened and after repeated restarts mysql innodb detection worked ,nine days gone it did happened again but here are the results of those commands:-

[email protected] [~]# ls -ld /tmp
drwxrwxrwt 9 root root 507904 May 17 19:50 /tmp/
[email protected] [~]# lsattr -d /tmp
----------I-- /tmp
[email protected] [~]# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 59G 17G 39G 31% /
tmpfs 5.9G 0 5.9G 0% /dev/shm
/dev/md0 847G 187G 617G 24% /home
/usr/tmpDSK 9.9G 190M 9.2G 2% /tmp



BTW i am using /dev/shm as temp directory for mysql