The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

(Rare?) New Account UserName Bug

Discussion in 'General Discussion' started by randomuser, Aug 30, 2005.

  1. randomuser

    randomuser Well-Known Member

    Joined:
    Jun 25, 2005
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    Hi, here's a story of an interesting (cPanel/WHM bug?) I ran into earlier this evening. Whether anyone else will find it interesting is arguable :) I am going to use "wwwabcd" as the account name.

    Around 7:15PM this evening, we receive an email from cpanel@server, informing us that a new account has been created (subject line: "New account on server").

    +===================================+
    | New Account Info |
    +===================================+
    | Domain: domain.com
    | Ip: x.x.x.x (n)
    | HasCgi: y
    | UserName: abcd
    | PassWord: xxxxxx
    | CpanelMod: x
    | HomeRoot: /home
    | Quota: 30 Meg
    | NameServer: ns1.domain.com
    | Contact Email: contact@email.com
    +===================================+
    Account was setup by: username (root)

    Looks good right? Well, 10 minutes later, we get the following email from Service Monitor with the subject line "apache on server failed": apache failed @ Tue Aug 30 19:24:52 2005. A restart was attempted automagicly.


    If you're wondering how Apache failing and the new account are related, I am getting to that. It is important to note that the UserName was not "abcd", but "wwwabcd". (I changed the actual username to abcd in this thread, but the real username does start with "www").

    What happened was, (somehow), the groupname in /etc/group was wwwwwwabcd - it should have been wwwabcd. I can't help but wonder:

    1. how the extra "www" was prepended to the group name, and
    2. why the "New Account Info" email from cPanel left off the www. (edit: update below)

    For anyone else that may come across this bug and happen to be reading this thread, the fix was too easy - vi/pico/whatever /etc/group and correct the group name. Then, restart apache.

    I should also note that there are numerous other accounts on the server that start with "www" that were set up without issue.

    If anyone has any thoughts/feedback/comments, I'd love to hear them.


    edit: I was notified this may be in Bugzilla. I am searching unsuccessfully. This is what I was told (thanks again to that person - I have tried calling this reseller to find out how they are adding the new accounts/domains/etc, no answer)

    "I think it stems from people trying to add domains with the www. subdomain before it and cPanel trying to work around that".

    Food for thought.

    edit 2: I checked all 3 domains this happened on (it happened on 2 more), and none have any subdomains (or addon/parked domains). This doesn't mean they didn't try to add any, just that none currently exist. Still waiting to hear from the customer so they can explain from A-Z how they are setting up these accounts.


    final edit: after speaking with the person who was creating these accounts, this is what I know to be true:

    For each of the 3 accounts they created via WHM, they accidentally left off the "www" part of the username (as reflected by the email I pasted above). Possibly /while/ the account was in the middle of being set up, the user changed the account name to "wwwabcd". The other possibility is that the account was finished being created on the server when the user modified the account name via WHM.


    I do consider this to be an important issue, as Apache will die due to the invalid group name in the VirtualHost directive. It cannot be restarted until the group name is correct in /etc/group.
     
    #1 randomuser, Aug 30, 2005
    Last edited: Aug 30, 2005
Loading...

Share This Page