The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RBLs under Exim4

Discussion in 'General Discussion' started by aussie, Jul 22, 2003.

  1. aussie

    aussie Member

    Joined:
    Jan 2, 2003
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Now that I've upgraded to exim4, I need to know how to put in a couple of rbls - e.g. ordb into the exim.conf file. Can someone post an idiots guide to this?

    cPanel.net Support Ticket Number:
     
  2. DataDork

    DataDork Active Member

    Joined:
    Apr 11, 2003
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    RBL Setup for cPanel/Exim 4

    pico /etc/exim.conf

    Look for the following entry

    #!!# ACL that is used after the RCPT command
    check_recipient:
    # Exim 3 had no checking on -bs messages, so for compatibility
    # we accept if the source is local SMTP (i.e. not over TCP/IP).
    # We do this by testing for an empty sending host field.
    accept hosts = :
    require verify = sender

    Right under that add the following, which can be modified to suit your situation.

    #!!# Spam control starts here:
    deny message = rejected because $sender_host_address is \
    is blacklisted at $dnslist_domain\n\
    $dnslist_text
    dnslists = spamhaus.relays.osirusoft.com=127.0.0.6: \
    sbl.spamhaus.org=127.0.0.2: \
    relays.ordb.org
    #!!# Spam control stops here

    Ctrl + X, answer "yes" to save the file "exim.conf"

    service exim restart

    Bingo, Bango!

    cPanel.net Support Ticket Number: n/a
     
    #2 DataDork, Jul 22, 2003
    Last edited: Jul 22, 2003
  3. aussie

    aussie Member

    Joined:
    Jan 2, 2003
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Unblocking for individual domains

    Thanks for that.

    I understood from reading a previous post that it would now be possible to have relay blocking for mail sent to the majority of domains on my server, but not have it for one or two specific ones. For example, I have a travel agency client that deals with Russia, and it seems half the ISPs in Russia are used for spam. I have to let these Russians spam servers talk to mine, but I only want to allow it for one domain.

    How can I do this?

    cPanel.net Support Ticket Number:
     
  4. mmkassem

    mmkassem Well-Known Member

    Joined:
    Oct 21, 2002
    Messages:
    390
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Egypt
    try the following just under
    require verify = sender


    [edit: try this]

    accept domains = domainname.com

    [/edit]
     
    #4 mmkassem, Jul 22, 2003
    Last edited: Jul 22, 2003
  5. cbwass

    cbwass Well-Known Member

    Joined:
    Mar 29, 2002
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    After configuring exim what would be the best way to check logs to see if it's working?

    cPanel.net Support Ticket Number:
     
  6. Marty

    Marty Well-Known Member

    Joined:
    Oct 10, 2001
    Messages:
    630
    Likes Received:
    1
    Trophy Points:
    18
    I have this in my exim.conf acl section:

    Code:
    begin acl
    
    
    #!!# ACL that is used after the RCPT command
    check_recipient:
      # Exim 3 had no checking on -bs messages, so for compatibility
      # we accept if the source is local SMTP (i.e. not over TCP/IP).
      # We do this by testing for an empty sending host field.
      accept  hosts = :
      require verify = sender
    
    #!!# Spam control starts here:
      deny message = rejected because $sender_host_address is \
                     is blacklisted at $dnslist_domain\n\
                     $dnslist_text
           dnslists = spamhaus.relays.osirusoft.com=127.0.0.6: \
                      sbl.spamhaus.org=127.0.0.2: \
                      relays.ordb.org
    #!!# Spam control stops here
    
      accept  domains = +local_domains
      accept  domains = +relay_domains
      accept  hosts = +relay_hosts
      accept  condition = ${perl{checkrelayhost}{$sender_host_address}}
    
      accept  hosts = +auth_relay_hosts
              endpass
              message = $sender_fullhost is currently not permitted to \
                            relay through this server. Perhaps you \
                            have not logged into the pop/imap server in the \
                            last 30 minutes or do not have SMTP Authentication turned on in your email client.
              authenticated = *
    
      deny    message = $sender_fullhost is currently not permitted to \
                            relay through this server. Perhaps you \
                            have not logged into the pop/imap server in the \
                            last 30 minutes or do not have SMTP Authentication turned on in your email client.
    
    Yet, when I got to the spamhaus site and get the test email to run tests on my rbl, I find that it is not working. I restarted exim after adding this to the config file. What am I doing wrong here.

    cPanel.net Support Ticket Number:
     
  7. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    Re: RBL Setup for cPanel/Exim 4

    What does this 127.0.0.6 and 127.0.0.2 do ??

    cPanel.net Support Ticket Number:
     
  8. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    Change you code to this:

    dnslists = spamhaus.relays.osirusoft.com : \
    sbl.spamhaus.org : \
    relays.ordb.org
    #!!# Spam control stops here

    Haven't seen 'sbl.spamhaus.org' so not sure how that one works.

    cPanel.net Support Ticket Number:
     
  9. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
  10. DataDork

    DataDork Active Member

    Joined:
    Apr 11, 2003
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    RBL Information Update

    Good Morning Everyone!

    Let me catch up...

    cbwass - To see if your RBL list is working, simply pico /var/log/exim_mainlog and do a search for ordb or spamhaus.


    anand - For more information on Spamhaus filter, check out this link; http://www.spamhaus.org/sbl/howtouse.html

    My "Spam" filters are working, just ask my clients :D

    Good luck guys!

    cPanel.net Support Ticket Number: n/a
     
  11. ccccanada

    ccccanada Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    16
    how can i prevent the next update from deleting the RBL data i have entered in exim.conf

    I did it a couple of days ago and today all the RBL info was gone.

    Thanks

    cPanel.net Support Ticket Number:
     
  12. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    say the magic words ;-)

    chattr +i /etc/exim.conf

    cPanel.net Support Ticket Number:
     
  13. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    forgot to add this, incase you again think about making any changes to exim.conf just do

    chattr -i /etc/exim.conf

    make changes and chattr +i it back to cpanel update can't write to it.

    cPanel.net Support Ticket Number:
     
  14. ccccanada

    ccccanada Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    16
    i hope i understood correctly

    now that i have put the RBL's back again i should
    chattr +i /etc/exim.conf

    and if i want to change it then i should first
    chattr -i /etc/exim.conf
    then do my changes and after saving them again
    chattr +i /etc/exim.conf

    Sorry for being so stupid I just want to make sure.

    Thanks

    cPanel.net Support Ticket Number:
     
  15. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    np

    you have understood it 100% correct ;)

    cPanel.net Support Ticket Number:
     
  16. ccccanada

    ccccanada Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    16
    Thank you very much!!

    cPanel.net Support Ticket Number:
     
  17. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    u r welcome :D

    cPanel.net Support Ticket Number:
     
  18. goodmove

    goodmove Well-Known Member

    Joined:
    May 12, 2003
    Messages:
    624
    Likes Received:
    0
    Trophy Points:
    16
    Have you tried to make those changes through the new "Exim Configuration Editor" in WHM? Then you wan't have to worry about Cpanel updates.
     
  19. ccccanada

    ccccanada Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    16
    I have looked in WHM but i could not see the "Exim Configuration Editor"

    What section would that be under??

    cPanel.net Support Ticket Number:
     
  20. goodmove

    goodmove Well-Known Member

    Joined:
    May 12, 2003
    Messages:
    624
    Likes Received:
    0
    Trophy Points:
    16
    You will need to update Cpanel to one of the latest versions to get the exim editor option.
     
Loading...

Share This Page