The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

rdate down?

Discussion in 'General Discussion' started by PPNSteve, Dec 26, 2009.

  1. PPNSteve

    PPNSteve Well-Known Member

    Joined:
    Mar 13, 2003
    Messages:
    393
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Somewhere in Ilex Forest
    cPanel Access Level:
    Root Administrator
    Twitter:
    Server Time
    rdate: timeout for rdate.cpanel.net

    Down?

    other sync URLs? where to config them?
     
  2. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    I was unable to reproduce a network time-out when testing from three different external locations; however, there are multiple possible reasons why this could occur. This could be either a temporary issue with the specific httpupdate/time server being connected to, a firewall configuration if one is used on the local system, or it could be localized to an upstream data center or network carrier.

    Via root SSH access, please let us know the output of the following command:
    Code:
    # ping -vc10 rdate.cpanel.net
    # traceroute -v rdate.cpanel.net
    
    For potential alternatives (via IP addresses), the following command could be used:
    Code:
    # dig rdate.cpanel.net +noall +answer
    I recommend using NTP via a customized NTP daemon ("ntpd") configuration so that a service will stay running to regulate the accuracy of the local system time. For details, I would suggest ensuring your system has the "ntp" package installed and then refer to official manual ("man") documentation pages using the following commands:
    Code:
    # man ntpd
    # man ntp.conf
    If the software package "ntp" is installed here is an alternative to "rdate" that will work when the NTP daemon ("ntpd") is not yet enabled:
    Code:
    # ntpdate -v clock.isc.org
     
    #2 cPanelDon, Dec 26, 2009
    Last edited: Dec 26, 2009
  3. rkgroups

    rkgroups Member

    Joined:
    Nov 12, 2006
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Hi

    I am facing the similar error. However, I am able to ping and tracert your servers.

    I don't have NTP installed. I don't have much technical expertise.

    Can you tell me if I can manually change the time? Or how to solve this problem?
    rdate: timeout for rdate.cpanel.net
     
  4. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Do you have any firewall configurations in-place? It is possible that rdate may be unable to communicate via the required ports (e.g., destination port 37, for rdate, and destination port 123, for ntp).

    On a Linux system with iptables, the following may be used to verbosely list all iptables rules:
    Code:
    # iptables -L -nv
    If there are custom rules (more than just the stock-default entries), I would consider temporarily stopping the firewall; the procedure for this may vary depending on how the firewall rules were setup.

    Warning: Caution should be exercised to avoid accidental connectivity loss when temporarily shutting down any active firewalls; if there is any uncertainty regarding the firewall configuration I recommend consulting with the hosting service provider or applicable on-site data center staff.

    As an example, if iptables is used alone (without any wrapper scripts like CSF or APF) then the following should perform the step of saving any current rules, then stopping the firewall:
    Code:
    # /etc/init.d/iptables save
    # /etc/init.d/iptables stop
    If an iptables wrapper script was used to configure the firewall then a different procedure may be necessary; here is an example if using CSF as the iptables wrapper:
    Code:
    # /usr/sbin/csf -f

    Manually running rdate or ntpdate may be performed as seen in the following examples:

    For rdate, via TCP, destination port 37:
    Code:
    # rdate -s rdate.cpanel.net
    For rdate, via UDP, destination port 37:
    Code:
    # rdate -s -u rdate.cpanel.net
    For ntpdate, via UDP, destination port 123, with verbose output:
    Code:
    # ntpdate -v clock.isc.org

    Installing the NTP software package "ntp" will provide both the NTP daemon "ntpd" as well as the utility "ntpdate" to manually set time when not running ntpd; the following commands may be used to accomplish the installation, varying depending on the OS:

    For CentOS/RHEL (i.e., RPM-based Linux):
    Code:
    # /scripts/ensurerpm ntp
    For FreeBSD:
    Code:
    # /scripts/ensurepkg ntp
     
  5. PPNSteve

    PPNSteve Well-Known Member

    Joined:
    Mar 13, 2003
    Messages:
    393
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Somewhere in Ilex Forest
    cPanel Access Level:
    Root Administrator
    Twitter:
    Code:
    root@svr2 [~]# ping -vc10 rdate.cpanel.net
    PING httpupdate.cpanel.net (208.74.121.37) 56(84) bytes of data.
    64 bytes from httpupdate5.cpanel.net (208.74.121.37): icmp_seq=1 ttl=54 time=1.13 ms
    64 bytes from httpupdate5.cpanel.net (208.74.121.37): icmp_seq=2 ttl=54 time=1.12 ms
    64 bytes from httpupdate5.cpanel.net (208.74.121.37): icmp_seq=3 ttl=54 time=1.15 ms
    64 bytes from httpupdate5.cpanel.net (208.74.121.37): icmp_seq=4 ttl=54 time=1.15 ms
    64 bytes from httpupdate5.cpanel.net (208.74.121.37): icmp_seq=5 ttl=54 time=2.10 ms
    64 bytes from httpupdate5.cpanel.net (208.74.121.37): icmp_seq=6 ttl=54 time=1.17 ms
    64 bytes from httpupdate5.cpanel.net (208.74.121.37): icmp_seq=7 ttl=54 time=1.19 ms
    64 bytes from httpupdate5.cpanel.net (208.74.121.37): icmp_seq=8 ttl=54 time=1.17 ms
    64 bytes from httpupdate5.cpanel.net (208.74.121.37): icmp_seq=9 ttl=54 time=1.15 ms
    64 bytes from httpupdate5.cpanel.net (208.74.121.37): icmp_seq=10 ttl=54 time=1.13 ms
    
    --- httpupdate.cpanel.net ping statistics ---
    10 packets transmitted, 10 received, 0% packet loss, time 13044ms
    rtt min/avg/max/mdev = 1.124/1.251/2.106/0.287 ms
    no issues there, just no answer for the rdate request cmd

    Didn't try that as we want as few extra daemons running as possible.

    tried that, it DID update the system clock.. still we'd like the normal cPanel automated one to work again..

    Code:
    root@svr2 [~]# rdate -s -u rdate.cpanel.net
    rdate: timeout for rdate.cpanel.net
    root@svr2 [~]# rdate -s -u 208.74.121.37
    rdate: timeout for 208.74.121.37
    
     
    #5 PPNSteve, Mar 16, 2010
    Last edited: Mar 16, 2010
  6. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    NTPd should be very low on resource usage; I'm not aware of any significant load increase as a result of running ntpd to maintain accurate system time.

    The UDP option may not work as I first believed; however, the default TCP method should work without issue, as seen below:
    Code:
    # rdate -s rdate.cpanel.net
    To further clarify, it is the TCP method that is used by cPanel, as seen in the following example entry in rc.local:
    Code:
    # grep rdate /etc/rc.d/rc.local
    rdate -s rdate.cpanel.net&
     
  7. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Expanding upon the last message, when I tested the specific httpupdate mirror IP address I was able to display the retrieved date and time via the rdate option "-p" for print:
    Code:
    # rdate -p rdate.cpanel.net
    rdate: [rdate.cpanel.net]	Sat Mar 20 03:14:01 2010
    
    # rdate -ps rdate.cpanel.net
    rdate: [rdate.cpanel.net]	Sat Mar 20 03:14:02 2010
    
    # rdate -p 208.74.121.37
    rdate: [208.74.121.37]	Sat Mar 20 03:16:01 2010
    
    # rdate -ps 208.74.121.37
    rdate: [208.74.121.37]	Sat Mar 20 03:16:03 2010
     
  8. nikolasd

    nikolasd Registered

    Joined:
    May 28, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I have the same problem with rdate. I get the error "rdate: timeout for rdate.cpanel.net" either from whm or SSH.

    I am on a VPS, running iptables (where i have added the port 37 and 123, although I am not sure if I have done it correctly).

    Whenever I stop iptables rdate commands returns successfully, but when iptables is running I keep getting that error.

    Has something to do with rdate, iptables, or the fact that I am on a VPS?
     
  9. vheeds

    vheeds Member

    Joined:
    Feb 22, 2010
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    >>Has something to do with rdate, iptables, or the fact that I am on a VPS?

    Make sure you are allowing the rdate port of 37 to communicate through your firewall.

    You can accomplish the above task by running these commands in your server

    iptables -A INPUT -p tcp --sport 37 -j ACCEPT
    iptables -A OUTPUT -p tcp --dport 37 -j ACCEPT
     
  10. nikolasd

    nikolasd Registered

    Joined:
    May 28, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    rdate problem SOLVED!

    Thanks a lot, I had not added the INPUT rule! No it works great!
     
  11. PPNSteve

    PPNSteve Well-Known Member

    Joined:
    Mar 13, 2003
    Messages:
    393
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Somewhere in Ilex Forest
    cPanel Access Level:
    Root Administrator
    Twitter:
    checked IPTables.. port37 is allowed in/out.

    Code:
    root@svr2 [~]# rdate -s rdate.cpanel.net
    rdate: timeout for rdate.cpanel.net
    root@svr2 [~]# ping rdate.cpanel.net
    PING httpupdate.cpanel.net (208.82.118.100) 56(84) bytes of data.
    64 bytes from 208.82.118.100: icmp_seq=1 ttl=52 time=52.2 ms
    64 bytes from 208.82.118.100: icmp_seq=2 ttl=52 time=52.5 ms
    64 bytes from 208.82.118.100: icmp_seq=3 ttl=52 time=53.6 ms
    64 bytes from 208.82.118.100: icmp_seq=4 ttl=52 time=52.9 ms
    64 bytes from 208.82.118.100: icmp_seq=5 ttl=52 time=54.4 ms
    64 bytes from 208.82.118.100: icmp_seq=6 ttl=52 time=52.4 ms
    64 bytes from 208.82.118.100: icmp_seq=7 ttl=52 time=54.7 ms
    64 bytes from 208.82.118.100: icmp_seq=8 ttl=52 time=52.5 ms
    64 bytes from 208.82.118.100: icmp_seq=9 ttl=52 time=54.4 ms
    64 bytes from 208.82.118.100: icmp_seq=10 ttl=52 time=53.0 ms
    
    --- httpupdate.cpanel.net ping statistics ---
    10 packets transmitted, 10 received, 0% packet loss, time 13153ms
    rtt min/avg/max/mdev = 52.275/53.307/54.771/0.890 ms
    
    still not updating properly.. and this does run when upcp is run does it not? (so we get daily time syncs)
     
Loading...

Share This Page