rDNS > and EHLO/HELOs do not match

Florinpop

Registered
Feb 9, 2014
4
0
1
cPanel Access Level
Root Administrator
Hello,
I had an dedicated server with cpanel administration. the hostname is vps.example.com. I have 3 ips with different RDNS for each one. 2 weeks ago ours ips get listed in the v4bl.org black list. they said that we need to fix the RDNS issue. We did it , we put the right rdns for each ip . When we cont the v4bl.org to delist us the respond that :

All IPs have been reprocessed and they all fail FCrDNS checks (Their rDNS
and EHLO/HELOs do not match):
xxx.xxx.xx.xx.x1 rDNS=*mail.example1.com <http://mail.example1.com>*EHLO/HELO=*vps.example.com http://vps.example.com>*
178.157.95.34 rDNS=*mail.example2.com <http://mail.example2.com>*EHLO/HELO=*vps.example.com <http://vps.example.com>*
178.157.95.35 rDNS=*mail.example3.com <http://mail.example3.com>*EHLO/HELO=*vps.example.com <http://vps.example.com>

On /http://multirbl.valli.org we made the FCrDNS test and we get ok everiwhere for all three ips.

I hope i was enaught explicite.

Is any posibility to fix this issue prom CPanel administration ?

What we need to do ?
 

Florinpop

Registered
Feb 9, 2014
4
0
1
cPanel Access Level
Root Administrator
Is enought to do only this part ?

Configuring Exim from WHM

or i need to do also the Creating and Editing the Appropriate Files , Editing /etc/mailhelo and Editing /etc/mailips ?
 

Florinpop

Registered
Feb 9, 2014
4
0
1
cPanel Access Level
Root Administrator
wright now in my vhm i have selected at "Send mail from account’s dedicated IP address " on.
if i turn off , "on" became availeble at 'Reference /etc/mailhelo for outgoing SMTP HELO" and "Reference /etc/mailips for outgoing SMTP connections" . Its enought to set "ön" or i still need to edit this two file ?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
Hello :)

If "Send mail from account’s dedicated IP address" is selected, /usr/local/cpanel/scripts/updateuserdomains will be used to automatically populate /etc/mailhelo and /etc/mailips, overriding your changes. You can enable this option, and then run the command manually just for verification:

Code:
/usr/local/cpanel/scripts/updateuserdomains
Then, manually review /etc/mailhelo to ensure it has the correct entries.

Thank you.