The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"Read-only file system"

Discussion in 'General Discussion' started by dendis, Nov 17, 2004.

  1. dendis

    dendis Well-Known Member

    Joined:
    Jul 18, 2003
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    Once you try to create any file you get:
    touch: creating `test.txt': Read-only file system

    It is strange, week ago 1 box get this problem.
    Today another.

    Anyone else got this problem ?

    Any ideas how-to fix or why it happens that the whole HDD gets read-only flag.
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Are you definitely booted into the correct run level?

    Have tried umount'ing the disk and mounting it again through fstab settings:

    umount /dev/XXX
    mount -a

    Have you checked /etc/fstab to make sure that hasn't been changed to mount disks read only?
     
  3. StevenC

    StevenC Well-Known Member

    Joined:
    Jan 1, 2004
    Messages:
    254
    Likes Received:
    0
    Trophy Points:
    16
    Are you running 2.6 kernel? 2.6 kernel has a habit of mounting the filesystems as read only
     
  4. dendis

    dendis Well-Known Member

    Joined:
    Jul 18, 2003
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    Here it is:

    SERVER1
    -------------
    LABEL=/ / ext3 defaults,usrquota 1 1
    LABEL=/boot /boot ext3 defaults 1 2
    none /dev/pts devpts gid=5,mode=620 0 0
    none /proc proc defaults 0 0
    none /dev/shm tmpfs defaults 0 0
    /dev/hda3 swap swap defaults 0 0
    /dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
    /dev/hdb1 /mnt/backup ext3 defaults 0 0

    SERVER2
    -------------
    /dev/hda5 / ext3 defaults,usrquota 1 1
    /dev/hda1 /boot ext3 defaults 1 2
    none /dev/pts devpts gid=5,mode=620 0 0
    none /proc proc defaults 0 0
    /dev/hda2 /tmp ext3 noexec,nosuid,nodev,rw 1 2
    /dev/hda3 swap swap defaults 0 0
    /dev/hdc1 /backup ext3 defaults 1 2


    It looks like normal ?

    There were no any reboots for the past 3 months both server were runnig fine.

    Also one server is using RHE with 2.6.7 #2 SMP kernel
    Another RH9 2.4.26-ow3 #2 SMP

    BUT - sometimes in WHM I see in "Service Status" link "NO DMA - click to enable", I do this, but in few days I see the same message again.
    Any ideas What can couse it ?

    can it be because HDD is about 80% full and server load is about 2 all the time ?
     
  5. Marty

    Marty Well-Known Member

    Joined:
    Oct 10, 2001
    Messages:
    630
    Likes Received:
    1
    Trophy Points:
    18
    I had this happen and an fsck showed that there were a lot of IO errors. As best we could tell, under high disk usage, the system was going to read only status. The datacenter replaced the harddrive and reinstalled everything. After that, all was well. I would suggest that you make sure you have good backups.
     
  6. StevenC

    StevenC Well-Known Member

    Joined:
    Jan 1, 2004
    Messages:
    254
    Likes Received:
    0
    Trophy Points:
    16
    2.6 will go into readonly if there are drive errors.
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Yup. As already mentioned, might be a good idea to secure your backups and have your NOC stress-test the disk and/or run a surface scan on it.
     
Loading...

Share This Page