The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Rebuild Apache fails ; RAM related?

Discussion in 'EasyApache' started by designarea, Jan 14, 2006.

  1. designarea

    designarea Member

    Joined:
    Oct 27, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Hi there,

    I am trying to add some modules (imap, mcrypt, gd and curl) to my Apache, but every time I do it, it fails. Here is the complete output on WHM

    Code:
    Apache Build/Upgrade
    
    Main >> Software >> Apache Update
    Building Apache Config.....Done
    Downloading and compiling apache+modules....
    
    Verifying archive integrity... All good.
    Uncompressing buildapache................................................................................................................................
    Verifying compiler and libs....Verifying installation....wget is installed and is the latest version.
    Gathering header information file(s) from server(s)
    Server: CentOS-3 - Addons
    Server: CentOS-3 - Base
    Server: CentOS-3 - Extras
    Server: CentOS-3 - Updates
    Finding updated packages
    Downloading needed headers
    No actions to take
    ncurses is installed and is the latest version.
    ncurses-devel is installed and is the latest version.
    gettext is installed and is the latest version.
    gdbm is installed and is the latest version.
    gdbm-devel is installed and is the latest version.
    db4 is installed and is the latest version.
    db4-devel is installed and is the latest version.
    patch is installed and is the latest version.
    glibc-kernheaders is installed and is the latest version.
    pam-devel is installed and is the latest version.
    krb5-devel is installed and is the latest version.
    openssl is installed and is the latest version.
    openssl-devel is installed and is the latest version.
    flex is installed and is the latest version.
    bison is installed and is the latest version.
    glibc-devel is installed and is the latest version.
    gcc is installed and is the latest version.
    gcc-c++ is installed and is the latest version.
    libgcc is installed and is the latest version.
    cpp is installed and is the latest version.
    libstdc++ is installed and is the latest version.
    libstdc++-devel is installed and is the latest version.
    libjpeg is installed and is the latest version.
    libjpeg-devel is installed and is the latest version.
    libpng is installed and is the latest version.
    libpng-devel is installed and is the latest version.
    libpng10 is installed and is the latest version.
    libpng10-devel is installed and is the latest version.
    libtiff is installed and is the latest version.
    libtiff-devel is installed and is the latest version.
    XFree86-libs is installed and is the latest version.
    XFree86-devel is installed and is the latest version.
    pspell is installed and is the latest version.
    pspell-devel is installed and is the latest version.
    zlib is installed and is the latest version.
    zlib-devel is installed and is the latest version.
    aspell is installed and is the latest version.
    aspell-devel is installed and is the latest version.
    libtool is installed and is the latest version.
    automake is installed and is the latest version.
    libungif-devel is installed and is the latest version.
    Gathering header information file(s) from server(s)
    Server: CentOS-3 - Addons
    Server: CentOS-3 - Base
    Server: CentOS-3 - Extras
    Server: CentOS-3 - Updates
    Finding updated packages
    Downloading needed headers
    No actions to take
    Done
    Done
    ********************************
    This is buildapache version 10.8.1
    ********************************
    buildapache configured from Web Host Manager
    Apache configured from Web Host Manager!
    /etc/rc.d/init.d/httpd start: httpd started
    Setting /home permissions to 0711......Done
    Setting permissions for.....omniusg......Done
    Untarring mcryptDone
    
    configure libmcrypt-2.5.7...(--prefix=/usr --disable-posix-threads).... . . . . . . . . . . . . . . . . . . . . . . . . . . . Done
    
    make -j 4 libmcrypt-2.5.7....... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done
    
    make libmcrypt-2.5.7...(install).... . . . . . . . . . . . . . . . . Done
    
    Untarring curl......Done
    
    configure curl-7.12.0...(--prefix=/usr --without-ssl).... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done
    
    make -j 4 curl-7.12.0....... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done
    
    make curl-7.12.0...(install).... . . . . Done
    
    Untarring imap....imap-devel is installed and is the latest version.
    Gathering header information file(s) from server(s)
    Server: CentOS-3 - Addons
    Server: CentOS-3 - Base
    Server: CentOS-3 - Extras
    Server: CentOS-3 - Updates
    Finding updated packages
    Downloading needed headers
    No actions to take
    Untarring php....Done
    Applying CURL curl_formfree patch
    patching file ext/curl/curl.c
    Hunk #1 succeeded at 590 (offset 45 lines).
    Hunk #2 succeeded at 904 (offset 19 lines).
    
    configure php-4.4.1...(--with-apxs=/usr/local/apache/bin/apxs --prefix=/usr/local --with-xml --enable-bcmath --enable-calendar --with-curl --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --with-imap --with-imap-ssl --with-kerberos --with-mcrypt --enable-magic-quotes --with-mysql=/usr --enable-discard-path --with-pear --enable-sockets --enable-track-vars --enable-versioning --with-zlib).... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done
    
    [COLOR=Red]configure: error: build test failed. Please check the config.log for details.[/COLOR]
    
    make -j 4 php-4.4.1...(clean).... Done
    
    make -j 4 php-4.4.1....... Done
    
    make php-4.4.1...(install).... Done
    
    /etc/rc.d/init.d/httpd start: httpd started
    
    configure php-4.4.1...(--prefix=/usr --with-xml --enable-bcmath --enable-calendar --with-curl --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --with-imap --with-imap-ssl --with-kerberos --with-mcrypt --enable-magic-quotes --with-mysql=/usr --enable-discard-path --with-pear --enable-sockets --enable-track-vars --enable-versioning --with-zlib).... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done
    
    [COLOR=Red]configure: error: build test failed. Please check the config.log for details.[/COLOR]
    
    make -j 4 php-4.4.1...(clean).... Done
    
    make -j 4 php-4.4.1....... Done
    
    make php-4.4.1...(install).... Done
    
    initfpsuexec: using apache 1.x support
    PHP version file has been updated to 4.4.1
    Executing /scripts/postbuildapache (if exists)...Done
    /etc/rc.d/init.d/httpd start: httpd started
        
    Attempting to restart httpd 	
    
    Waiting for httpd to restart....
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    finished.
    
    
    
    After that, Apache becomes unstable. Clicking on a -PHP- link, sometimes causes a browser to download the page instead of displaying it (this means that the PHP code is not executed.) And sometimes. even WHM does not work at all, unless I restart Apache.


    First question:
    I am trying to do that on a 256Mb VPS. Does this amount of memory affect the build of Apache through WHM? Does the amount of RAM affect any operation of Cpanel in general?

    Second one:
    if it is not RAM related, what can cause this? Have you faced such a problem again?

    Third one:
    Is there a guide, that will allow me to rebuild a "fresh" Apache (even through SSH), since rebuilding it through Cpanel might leave it unstable?


    Thank you very much !


    PS: Versions:
    WHM 10.8.0 cPanel 10.8.1-R113
    CentOS 3.5 i686 - WHM X v3.1.0
     
  2. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    SSH to the server

    remove the cpapache folder from /home

    then try running

    /scripts/easyapache with selecting the necessary modules enabled.
     
    #2 aby, Jan 14, 2006
    Last edited: Jan 14, 2006
  3. designarea

    designarea Member

    Joined:
    Oct 27, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Thank's for your help ! I am currently re-building it. I hope it will be producing a stable apache, since both Apache and WHM are very unstable right now. (I assume removing the old directory will help)

    1. With easyapache, I cannot select all the modules I want. There are 4-5 pre-configured options, and one "advanced" one, that does not give me all available modules to choose from... How can I select imap fro example?

    2. Does RAM affect or even "block" Cpanel's operations, regarding Apache rebuilds?
     
  4. designarea

    designarea Member

    Joined:
    Oct 27, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Well, I didn't know how to navigate through the menu...
    No I've done it. I've selected all the options I wanted, and I am rebuilding Apache. Cross your fingers :)
     
  5. designarea

    designarea Member

    Joined:
    Oct 27, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Houston we 've got a problem...


    Apache still refuses to compile successfully. I 'm using either Cpanel or command line (easyapache) but .... nothing.

    Each time, I get a different error:

    1. modules selected (easy apache)
    curl
    curl ssl
    mcrypt
    gd
    imap

    Code:
    *** Changes Saved
    
    /etc/rc.d/init.d/httpd start: httpd started
    Setting /home permissions to 0711......Done
    Setting permissions for.....omniusg......Done
    initfpsuexec: using apache 1.x support
    [COLOR=Red]chattr: Inappropriate ioctl for device while reading flags on _vti_bin/fpexe
    chattr: Inappropriate ioctl for device while reading flags on _vti_bin/fpexe[/COLOR]
    PHP version file has been updated to 4.4.1
    Executing /scripts/postbuildapache (if exists)...Done
    /etc/rc.d/init.d/httpd start: httpd started
    Waiting for httpd to restart..............finished.
    
    root     29444  1.8  0.0 10176 5332 ?        S    14:20   0:00 /usr/local/apache/bin/httpd -DSSL
    httpd started ok

    2. modules selected (easy apache)
    curl
    curl ssl
    mcrypt
    gd
    Code:
    *** Changes Saved
    
    /etc/rc.d/init.d/httpd start: httpd started
    Setting /home permissions to 0711......Done
    Setting permissions for.....omniusg......Done
    15:27:28 URL:http://layer1.cpanel.net/buildapache/1/libmcrypt-2.5.7.tar.gz [523321/523321] -> "libmcrypt-2.5.7.tar.gz" [1]
    Untarring mcryptDone
    configure libmcrypt-2.5.7...(--prefix=/usr --disable-posix-threads).............................Done
    make -j 4 libmcrypt-2.5.7...................................................Done
    make libmcrypt-2.5.7...(install).....Done
    15:28:45 URL:http://layer1.cpanel.net/buildapache/1/curl-7.12.0.tar.gz [1520041/1520041] -> "curl-7.12.0.tar.gz" [1]
    Untarring curl......Done
    configure curl-7.12.0...(--prefix=/usr)..................................................................................................Done
    make -j 4 curl-7.12.0...........................................................................................Done
    make curl-7.12.0...(install)........Done
    15:32:19 URL:http://layer1.cpanel.net/buildapache/1/php-4.4.1.tar.gz [5110458/5110458] -> "php-4.4.1.tar.gz" [1]
    Untarring php....Done
    Applying CURL curl_formfree patch
    patching file ext/curl/curl.c
    Hunk #1 succeeded at 590 (offset 45 lines).
    Hunk #2 succeeded at 904 (offset 19 lines).
    configure php-4.4.1...(--with-apxs=/usr/local/apache/bin/apxs --prefix=/usr/local --with-xml --enable-bcmath --enable-calendar --with-curl --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --with-mcrypt --enable-magic-quotes --with-mysql=/usr --enable-discard-path --with-pear --enable-sockets --enable-track-vars --enable-versioning --with-zlib)..............................................................................................................Done
    make -j 4 php-4.4.1...(clean)....Done
    make -j 4 php-4.4.1...........................................................................................................................................Done
    [COLOR=Red]make: *** [ext/standard/assert.lo] Error 1
    make: *** Waiting for unfinished jobs....[/COLOR]
    make php-4.4.1...(install)..................................................................................................................................................................................Done
    /etc/rc.d/init.d/httpd start: httpd started
    configure php-4.4.1...(--prefix=/usr --with-xml --enable-bcmath --enable-calendar --with-curl --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --with-mcrypt --enable-magic-quotes --with-mysql=/usr --enable-discard-path --with-pear --enable-sockets --enable-track-vars --enable-versioning --with-zlib)............................................................................Done
    make -j 4 php-4.4.1...(clean).....Done
    make -j 4 php-4.4.1................................................................................................................................................Done
    make php-4.4.1...(install).............................Done
    initfpsuexec: using apache 1.x support
    [COLOR=Red]chattr: Inappropriate ioctl for device while reading flags on _vti_bin/fpexe
    chattr: Inappropriate ioctl for device while reading flags on _vti_bin/fpexe[/COLOR]
    PHP version file has been updated to 4.4.1
    Executing /scripts/postbuildapache (if exists)...Done
    /etc/rc.d/init.d/httpd start: httpd started
    Waiting for httpd to restart..............finished.
    
    root     25632  1.1  0.0  9276 4980 ?        S    15:43   0:00 /usr/local/apache/bin/httpd -DSSL
    
    httpd started ok



    Any ideas?
     
  6. designarea

    designarea Member

    Joined:
    Oct 27, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Hi there Izzee and thanks for the reply

    Well, the problem was that when trying with easyapache + 4modules +imap (case C1), I go these errors and the procedure ended after 20-30 seconds. You can see the first piece of "code". This was the whole output...

    Then I tried to add only Curl, curl SSL, GD and mcrypt (not imap) (case C2), and I got the second error (assert.lo).

    Then I tried (for the 20th time) to build it, via WHM (case W2) this time. It finished without any problems a few seconds ago. But I excluded imap, as it seems that 9 out of 10 times I try to add imap, I received some kind of an error...

    Strange...
    I just did the same procedure on another test VPS I have (Redhat 9 instead of CentOS).
    I did it via command-line (C1). I got a chattr error, but no other error ! ANd the procedure lasted 20 minutes or so, not 20 seconds...

    OK, I am trying again via easyapache
    ... adding only imap (compared to the previous configuration)

    Code:
    /etc/rc.d/init.d/httpd start: httpd started
    Setting /home permissions to 0711......Done
    Setting permissions for.....omniusg......Done
    initfpsuexec: using apache 1.x support
    chattr: Inappropriate ioctl for device while reading flags on _vti_bin/fpexe
    chattr: Inappropriate ioctl for device while reading flags on _vti_bin/fpexe
    PHP version file has been updated to 4.4.1
    Executing /scripts/postbuildapache (if exists)...Done
    /etc/rc.d/init.d/httpd start: httpd started
    Waiting for httpd to restart..............finished.

    Just 10 seconds... That was it. No imap installed ...
    AT least it seems so ...

    './configure' '--with-apxs=/usr/local/apache/bin/apxs' '--prefix=/usr/local' '--with-xml' '--enable-bcmath' '--enable-calendar' '--with-curl' '--enable-ftp' '--with-gd' '--with-jpeg-dir=/usr/local' '--with-png-dir=/usr' '--with-xpm-dir=/usr/X11R6' '--with-mcrypt' '--enable-magic-quotes' '--with-mysql=/usr' '--enable-discard-path' '--with-pear' '--enable-sockets' '--enable-track-vars' '--enable-versioning' '--with-zlib'






    I usually do it this way !






    PS. Does the RAM affect this procedure either when triggered via WHM or via command line?
     
  7. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    No, RAM will not affect the procedure when triggred from WHM or Shell. The apache compilation will take time depending on the RAM size.
     
  8. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Actually, it can fail due to memory allocation, in particular if you have WHM > Tweak Settings > The maximum memory a cPanel process can use before it is killed off > set too low. Make sure that value is at least 128
     
  9. designarea

    designarea Member

    Joined:
    Oct 27, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Thank you both !

    Actually, the minimum is already set at 128, so the procedure should not fail due to low memory.

    I took a look at the bug reports, and saw many similar bugs, caused by the imap module. I suppose it is just another bug ...
     
  10. seattlerocks

    seattlerocks Member

    Joined:
    Jun 7, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Seattle, WA
    Also go to php.ini and allow script execution to go for a longer duration is adviseable if in http rather than ssh :)
     
Loading...

Share This Page