Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

rebuild_phpconf errors that Apache httpd is disabled? [solution]

Discussion in 'EasyApache' started by R2B2, Jul 18, 2014.

  1. R2B2

    R2B2 Member

    Joined:
    Jul 29, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Just thought i'd share since i didn't see it anywhere in previous threads --

    ++++++++++++++++++++++++++++++
    root@server [~]# /usr/local/cpanel/bin/rebuild_phpconf 5 none fcgi 1
    ...
    php.conf updated to:
    ...
    ...
    FcgidWrapper /usr/local/cpanel/cgi-sys/php5 .php
    ...
    ...
    Restarting Apache
    info [rebuild_phpconf] Apache httpd is disabled, cannot be restarted.
    ++++++++++++++++++++++++++++++

    Solution?

    Remove the empty /etc/httpddisable disable file.

    (Then the next time you run that script it will try to restart httpd. Though you could just restart apache with `service httpd restart`)
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,617
    Likes Received:
    1,787
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello :)

    Yes, it's normal for Apache to fail starting if /etc/httpddisable exists as a file. This file is only created when you manually disable Apache in the service manager, or if you create the file via the command line.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice