The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Receiving 406 Not Acceptable error

Discussion in 'General Discussion' started by webnode, Sep 10, 2012.

  1. webnode

    webnode Registered

    Joined:
    Sep 10, 2012
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Hello

    I'm running into this new problem "406 Not Acceptable" when trying to update and submit content from admin panel of my site.
    Can any one please suggest how to resolve this issue?

    Here are the apache error log file details (domain name and ip are masked)

    /http://pastebin.com/Q8xGG4UA
    Access denied w - Pastebin.com

    Thanks
     
  2. azzureal

    azzureal Registered

    Joined:
    Sep 10, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
  3. PlotHost

    PlotHost Well-Known Member

    Joined:
    Apr 29, 2011
    Messages:
    253
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    US
    cPanel Access Level:
    Root Administrator
    Twitter:
  4. webnode

    webnode Registered

    Joined:
    Sep 10, 2012
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    I had asked them to disable mod_security on server though it is not safe, before knowing the solution from this thread. Now, i had asked them to reactivate mod_security and do the above mentioned changes and they had informed me that they had done it.
    But now i would to like whether they had really activated mod_security back, as i'm thinking that they are misleading me just by saying mod_security is activated.
    How can i check that mod_security is activated on server? Is there any script to check it or how can i do it?
     
  5. PlotHost

    PlotHost Well-Known Member

    Joined:
    Apr 29, 2011
    Messages:
    253
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    US
    cPanel Access Level:
    Root Administrator
    Twitter:
    Take a look here modsecurity.org/blog/archives/2007/02/weekly_sans_ris_1.html.
    Access your domain with domain.com/faq.php?... as it is in that post... You should get an error page if mod_security is enabled.
     
  6. webnode

    webnode Registered

    Joined:
    Sep 10, 2012
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Thanks plothost. Its working. Giving the 406 not acceptable error along with 404 not found

    The solutions mentioned in 2nd and 3rd posts for my previous issue are also working as now i can update content using my admin panel.
     

Share This Page