The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Recent Update Brome yum

Discussion in 'General Discussion' started by psychodreams, Sep 1, 2007.

  1. psychodreams

    psychodreams Well-Known Member

    Joined:
    Apr 14, 2004
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    6
    I have done nothing to the server but cpanel updates as they are released no When running cpanel updates its spitting out

    There was a problem importing one of the Python modules
    required to run yum. The error leading to this problem was:

    /usr/lib/python2.4/site-packages/rpm/_rpmmodule.so: undefined symbol: rpmdbCheckTerminate

    Please install a package which provides this module, or
    verify that the module is installed correctly.

    It's possible that the above module doesn't match the
    current version of Python, which is:
    2.4.3 (#1, Oct 23 2006, 14:19:47)
    [GCC 4.1.1 20060525 (Red Hat 4.1.1-1)]

    Now Cpanel updates are not working anyone know how to fix this
     
  2. Crazor

    Crazor BANNED

    Joined:
    May 11, 2007
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    0
    Upgrade your Python and everything should be ok
     
  3. psychodreams

    psychodreams Well-Known Member

    Joined:
    Apr 14, 2004
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    6
    :(

    I just installed the newest python and its spitting out the same error trying to use the old python
     
  4. psychodreams

    psychodreams Well-Known Member

    Joined:
    Apr 14, 2004
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    6
    also

    also when you install a newer python it installs to /usr/local/lib where as cpanels uses usr/lib/ well at least in my /usr/lib theres a python2.4 which was there before i even did anything but new installs sends it to python2.4 but the cpanel error is saying im using 2.4.3/ I had touched nothing until this occurred only performed cpanel updates as they came out.
    Can someone explain whats going on here. My box is hosed If i can do any cpanel updates and I cant even use yum
     
Loading...

Share This Page