The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Recent Update

Discussion in 'General Discussion' started by tompgl, Oct 30, 2007.

  1. tompgl

    tompgl Registered

    Joined:
    Jun 26, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I literally haven't touched my server in weeks, and BAM, right out of the blue i'm now getting hostname DNS errors and mail server issues. I figure it's either a hardware failure or a Cpanel update. I've managed to fix the hostname issue and part of the mail problem but outgoing mail from the nobody user is still blocked. Does anyone else have these symptoms or know how to fix it?

    Thanks
     
  2. gizzmo2006

    gizzmo2006 Active Member

    Joined:
    May 22, 2007
    Messages:
    36
    Likes Received:
    1
    Trophy Points:
    8
    Hello,

    got to "Tweak Settings" and uncheck " Prevent the user "nobody" from sending out mail to remote addresses (PHP and CGI scripts generally run as nobody if you are not using PHPSuexec and Suexec respectively.)".

    If you are running csf and using SMTP_BLOCK, you also have to enable SMTP_ALLOWLOCAL.

    Regards Frank
     
  3. tompgl

    tompgl Registered

    Joined:
    Jun 26, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    The nobody user toggle in Tweak Settings was unchecked, i'd already looked at that. What is csf? My mail server config is the cpanel default, i haven't customized it.

    Outgoing mail seems to work internally, for instance i can receive nobody user emails to my email address which is on the same mail server.

    Thanks
     
    #3 tompgl, Oct 31, 2007
    Last edited: Oct 31, 2007
Loading...

Share This Page