The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Recipient callout

Discussion in 'E-mail Discussions' started by gldickens3, Apr 5, 2008.

  1. gldickens3

    gldickens3 Member

    Joined:
    Apr 17, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    For some reason, I cannot get recipient callout to work with the exim configuration utility on cPanel 11. I need to implement recipient verification because I have another exim system that is acting as a relay for my cPanel system. Right now, a bounce back is created by the relay system every time that the cPanel system rejects a spam to the relay system creating collateral spam. I can fix this simply by having the relay system verify recipient callouts on the cpanel system, however, I cannot get recipient callouts to work. I have added the following line to the exim.conf file using the cpanel interface under the "check_recipient:" ACL:

    require verify = recipient/callout=defer_ok

    However, a simple telnet session shows that the cpanel system is still not doing the recipient callout since it continues to accept mail for users that don't exist.

    I have recipient callouts working correctly on other exim systems that are not running cpanel. So, I don't understand why this isn't working.

    Any help on debugging this would be greatly appreciated.

    Thanks,

    Gordon Dickens
     
  2. rvskin

    rvskin Well-Known Member
    PartnerNOC

    Joined:
    Feb 19, 2003
    Messages:
    400
    Likes Received:
    1
    Trophy Points:
    18
    Just find you post. I see this several times and quiet sure it is cPanel bug. When setting for 'Sender Verification Callouts' on the EXIM editor, is unchecked. cPanel simply remove all callout no matter it is on recipient or sender. For your case, enable 'Sender Verification Callouts' should leave your recipient callout unchanged. Be careful if you put something like recipient/callout=10m,defer_ok and uncheck 'Sender Verification Callouts', it will kill your exim all together. We don't use callout for several months, not sure if this bug has been fixed.
     
Loading...

Share This Page