Recommendations for PHP DSO

Mat-d-rat

Well-Known Member
Jul 30, 2003
108
2
168
"Recommendations for “PHP DSO” *
PHP DSO runs as the user nobody by default. In a shared hosting environment, this is a security issue. Learn More

  • If you use suPHP, you will add some security, but may experience performance issues on your server.
*These recommendations appear because you have “ea-php56-php” installed on your system."

After updating to apache 4 and changing some options around I'm getting this. I've tried form the help "We strongly recommend that you install either the ea-apache24-mod_ruid2 Apache module or the ea-apache24-mod_mpm_itk Apache module unless you have single-user system." used both and still get the same error, so not sure what to do?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,211
363
After updating to apache 4 and changing some options around I'm getting this. I've tried form the help "We strongly recommend that you install either the ea-apache24-mod_ruid2 Apache module or the ea-apache24-mod_mpm_itk Apache module unless you have single-user system." used both and still get the same error, so not sure what to do?
Hello,

Can you verify how you enabled Mod_Ruid2 or the ITK MPM? You can check to see which one is installed with the following commands:

Code:
rpm -qa|grep ruid2
rpm -qa|grep itk
Thank you.