The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Recompiling with FastCGI and disabling mod_ruid2 in EasyApache

Discussion in 'EasyApache' started by Archmactrix, Sep 1, 2012.

  1. Archmactrix

    Archmactrix Well-Known Member

    Joined:
    Jan 20, 2012
    Messages:
    132
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    I'm considering enabling FastCGI instead of DSO, but there is no option to enable it in EasyApache if mod_ruid2 is enabled.

    Of course I could recompile with Mod_ruid2 disabled in EasyApache before I recompiled again with FastCGI. Or is there an easier way to do it?
     
  2. minosjl

    minosjl Well-Known Member

    Joined:
    Jun 4, 2011
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hi,

    Please have a look at the below section in WHM panel.

    -----------------
    Main >> Apache Configuration >> PHP and SuExec Configuration
    ------------------

    Thank you.
     
  3. Archmactrix

    Archmactrix Well-Known Member

    Joined:
    Jan 20, 2012
    Messages:
    132
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    That option is not very helpful as I can't disable mod_ruid2 there or enable fastCGI.
     
  4. Eric

    Eric Administrator
    Staff Member

    Joined:
    Nov 25, 2007
    Messages:
    746
    Likes Received:
    11
    Trophy Points:
    18
    Location:
    Texas
    cPanel Access Level:
    Root Administrator
    Howdy,

    FastCGI and mod_ruid2 are not compatible. The only handlers you may use with ruid2 are suPHP and DSO.

    Thanks!
     
  5. Archmactrix

    Archmactrix Well-Known Member

    Joined:
    Jan 20, 2012
    Messages:
    132
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    I already know that.

    But my problem is, that FastCGI has no option in EasyApache if mod_ruid2 is enabled, and as I said it seems that I need to recompile with mod_ruid2 disabled, before FastCGI is an option in EasyApache and recompile again with it.
     
  6. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Since mod_ruid2 is an Apache module and compiled into Apache during EasyApache run, you cannot select FCGI when you have mod_ruid2 enabled. mod_ruid2 cannot be disabled in WHM > Apache Configuration > PHP and SuExec Configuration area nor in command line using "/usr/local/cpanel/bin/rebuild_phpconf" area. You must recompile Apache using EasyApache to de-select mod_ruid2 before you can utilize FCGI, yes.
     
  7. Archmactrix

    Archmactrix Well-Known Member

    Joined:
    Jan 20, 2012
    Messages:
    132
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
  8. vortexmx

    vortexmx Registered

    Joined:
    Nov 24, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I compiled Apache with mod_ruid2, but i want to disable it, but after recompile Apache using EasyApache and disabling mod_ruid2, all the config from httpd.conf still same, and WHM > Apache > Configuration > PHP and SuExec still saying "Ruid2 on", and i get "Internal Error".... how can i uninstall? or im doing something wrong?
     
Loading...

Share This Page