The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Reconfiguring Local Mail: This server will NOT serve as a mail exchanger for...

Discussion in 'E-mail Discussions' started by TechGuy, Jun 21, 2007.

  1. TechGuy

    TechGuy Well-Known Member

    Joined:
    Nov 29, 2001
    Messages:
    60
    Likes Received:
    0
    Trophy Points:
    6
    Whenever I edit a DNS zone on one of our servers, it says that "Reconfiguring Local Mail: This server will NOT serve as a mail exchanger for {domain name} mail." Unfortunately, it's wrong -- the server IS the local MX for that domain.

    On the other servers, this works GREAT and automatically removed the domain from the /etc/localhosts file. For some reason, on this server, it's incorrectly guessing that the MX is not itself. Does anyone have any idea how it comes to this conclusion, or what might be wrong?

    Thanks!
     
  2. TechGuy

    TechGuy Well-Known Member

    Joined:
    Nov 29, 2001
    Messages:
    60
    Likes Received:
    0
    Trophy Points:
    6
    Doh! I just found a mistake in our /etc/hosts file that was causing this problem.
     
  3. Dale S

    Dale S Member

    Joined:
    Sep 3, 2004
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    This server will NOT serve as a mail exchanger

    I think I'm having the same problem. Not sure what to look for in the /etc/hosts/ file.

    I found a few sites that I moved from another server and the SOA records are wrong. When I change the records and save the file I get the message "This server will NOT serve as a mail exchanger ". I tried other accounts by making a change on the expire time and suddenly I get the same message on it. In effect anytime I update a DNS record I lose the e-mail. All MX entries are correct when I make the update.
     
  4. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    What is your cPanel version?
     
  5. Dale S

    Dale S Member

    Joined:
    Sep 3, 2004
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    cpanel version

    My version is cPanel 11.11.0-S17997
     
  6. rhenderson

    rhenderson Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    785
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Oklahoma
    cPanel Access Level:
    Root Administrator
    Any fix for this I am am having the same issues.
     
  7. hydra

    hydra Well-Known Member

    Joined:
    Mar 26, 2008
    Messages:
    102
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Amsterdam, Netherlands
    :eek:
    Anything new here? i have the same problem.

    Ronald.
     
  8. rhenderson

    rhenderson Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    785
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Oklahoma
    cPanel Access Level:
    Root Administrator
    Wow talk about bringing up an old thread :) On the DNS entry/editor now there is a check box to force local mail.
     
  9. hydra

    hydra Well-Known Member

    Joined:
    Mar 26, 2008
    Messages:
    102
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Amsterdam, Netherlands
    Hi,

    Thank you for the reply.:D
    I know about the force local mail setting but i was wondering why some domains give this problem and others do not. I have a few domains that as soon as i change something in the DNS will disable local mail and the other domains do not. Strange behavior.:eek:

    Ronald.
     
  10. jfgarcia

    jfgarcia Registered

    Joined:
    Aug 27, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Try this.
    My problem was solved.
    http://forums.cpanel.net/showthread.php?p=415225#post415225
     
Loading...

Share This Page