The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RedHat 9 users (bind segfaulting)

Discussion in 'Bind / DNS / Nameserver Issues' started by cPanelNick, Nov 14, 2003.

  1. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    If you are getting a segmentation fault error with bind reloading, you need to update glibc again.

    The following is a list of glibc rpm status:

    glibc-2.3.2-27.9.7 = good glibc
    glibc-2.3.2-27.9.6 = bad glibc

    /scripts/updatenow
    rm -rf /root/.cpupdates
    /scripts/rpmup

    will install the 2.3.2-27.9.7 version. Is will also work around the the bug in 27.9.6 by setting

    LD_ASSUME_KERNEL = 2.2.5
     
  2. xphost

    xphost Well-Known Member

    Joined:
    Nov 12, 2003
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    really help, thanks
     
  3. zac-lw

    zac-lw Registered
    PartnerNOC

    Joined:
    Mar 20, 2002
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    it fixes stunnel segfaulting too
     
  4. DHL

    DHL Well-Known Member

    Joined:
    Mar 8, 2002
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    6
    The typo seems to have appeared back in named.conf on redhat 9 servers.

    controls {
    inet 127.0.0.1 allow { localhost; } keys { rndckey;


    Should be

    controls {
    inet 127.0.0.1 allow { localhost; } keys { rndc-key;

    If you get ndc reload errors.
     
  5. SkyfireMike

    SkyfireMike Member

    Joined:
    Aug 7, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    HELP!

    After I did this, now I'm receiving the following errors when running /scripts/upcp:

    rpm database is corrupt. rpm claims glibc is not installed. hackcheck cannot continue at /scripts/hackcheck line 89.

    Help help!
     
  6. Nico

    Nico Well-Known Member

    Joined:
    Dec 5, 2001
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Edmond, OK
    I had the same problem and a reboot got it going.
     
  7. SkyfireMike

    SkyfireMike Member

    Joined:
    Aug 7, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    I just rebooted my server, and I'm still getting this error.

    Also, when I try to rebuild the RPM database, I get this error:

    error: db4 error(16) from dbenv->remove: Device or resource busy

    Any ideas? :(
     
  8. JCave

    JCave Well-Known Member

    Joined:
    Feb 19, 2003
    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    6
    Actually this does not fix stunnel from seg. Just tried it and mine still seg.

    Peace Out
     
  9. sfield

    sfield Active Member

    Joined:
    Sep 8, 2003
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    When I try to run /scripts/updatenow/ I get the following:

    rsync: getaddrinfo: rsync.cpanel.net 873: Temporary failure in name resolution
    rsync error: error in socket IO (code 10) at clientserver.c(97)

    Not sure if this is caused by the bind problem on my server or by a problem with cpanels server?
     
  10. vbfred

    vbfred Registered

    Joined:
    Nov 18, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    change what's in your /etc/resolv.conf to a valid name server ip instead of 127.0.0.1, as your local named doesn't work and cannot resolve the cpanel domain.
     
  11. Snowman30

    Snowman30 Well-Known Member
    PartnerNOC

    Joined:
    Apr 7, 2002
    Messages:
    681
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    ive got this same error and changing 127.0.0.1 causes an ndc error
     
  12. kahoz

    kahoz Well-Known Member

    Joined:
    Nov 7, 2003
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Portugal
    i'm also getting an segfault and it no one of the solutions here work. :(

    Code:
    root@jupiter [/etc]# service named restart
    Stopping named: /etc/init.d/named: line 139: 25476 Segmentation fault      /usr/sbin/rndc stop >/dev/null 2>&1
                                                               [  OK  ]
    Starting named:                                            [  OK  ]
    WHM 9.9.9 cPanel 9.9.9-S15
    CentOS 3.4 i686 - WHM X v3.1.0

    edit:

    i found this http://grsecurity.net/pipermail/grsecurity/2005-February/000249.html
     
    #12 kahoz, Mar 25, 2005
    Last edited: Mar 25, 2005
  13. brentp

    brentp Well-Known Member

    Joined:
    Mar 11, 2004
    Messages:
    324
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Ayr, North Queensland, Australia
    Upgrade to CentOS 3.4 (yes, there are instructions on wht). And/or if you have sufficent knowledge of linux, upgrade to cenots4 (no public instructions yet). The only person i know that does it is steve from rack911.com.

    We tested it on my box and it worked flawlessly (except for a few /dev/pts errors which were rectified quickly). If you use centos4 make sure you set SELINUX to off.

    Regards,
    Brent
     
  14. kahoz

    kahoz Well-Known Member

    Joined:
    Nov 7, 2003
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Portugal
    :rolleyes:
     
  15. StevenC

    StevenC Well-Known Member

    Joined:
    Jan 1, 2004
    Messages:
    254
    Likes Received:
    0
    Trophy Points:
    16
    mv /lib/tls /lib/tls.disable
    service named restart
     
  16. foxboy

    foxboy Well-Known Member

    Joined:
    Sep 20, 2003
    Messages:
    66
    Likes Received:
    0
    Trophy Points:
    6
    THANK YOU VERY MUCH!

    This bugged me for a few weeks now, had to restart bind every day a few times.
     
Loading...

Share This Page