The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[RedHat] Exim: failed to expand condition "${perl{checkspam}}"

Discussion in 'General Discussion' started by SupaDucta, Oct 12, 2004.

  1. SupaDucta

    SupaDucta Active Member

    Joined:
    Oct 6, 2004
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    After a few issues Exim was reinstalled. Since it was reinstalled, one of our PHP mail() scripts used for user registration confirmation can't dispatch e-mails, so our users can't register at the moment.

    exim_mainlog:

    The mails get returned.

    However, exim_paniclog produces:

    Now, this is probably simple to configure using exim.conf editor in WHM but I really do not know what to enter and where.

    Mails sent to the same .post.htnet.hr or similar addresses through POP work, only e-mail sent through this form doesn't.

    We have recently had to reinstall Exim due to exim.conf issue mentioned in one of the threads here, and until then the latter script worked.

    Does this have something to do with this commented line in exim.conf:

    # host_accept_relay = localhost

    or is it some other setting?

    Thanks in advance ;)
     
  2. SupaDucta

    SupaDucta Active Member

    Joined:
    Oct 6, 2004
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    OK, reinstall fixed this. cPanel was rewriting the working exim.conf with it's default after every upgrade.

    However, one problem remains, and it is extremely annoying.

    Last night cPanel has upgraded to the latest release - WHM 9.9.3 cPanel 9.9.3-R17
    RedHat 7.3 i686 - WHM X v3.1.0. It has rewritten the exim.conf with the default one, Exim startup failed.

    I have restored the working conf, restarted Exim. Service is up, mails go through normally, no errors in Exim logs, no errors in exim.conf but WHM is reporting Exim as failed, and chkservd is harrassing me with e-mails on Exim being unable to start every 7-8 minutes!

    chkservd.log:

    /bin/pwd exists...

    Guys, does anyone know the fix for this? It is extremely annoying :(
     
    #2 SupaDucta, Oct 19, 2004
    Last edited: Oct 19, 2004
  3. nitromax

    nitromax Well-Known Member

    Joined:
    Feb 12, 2002
    Messages:
    189
    Likes Received:
    0
    Trophy Points:
    16
    Did you ever resolve this problem? I'm having the same thing:

    2004-12-15 13:26:13 1Ceemr-0002sJ-0g failed to expand condition "${perl{checkspam}}" for lookuphost router: Gid 646 is not permitted to relay mail at /etc/exim.pl line 352.
     
  4. avijit

    avijit Well-Known Member

    Joined:
    Jul 26, 2004
    Messages:
    116
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Does anybody have any solution to it . Even the /scripts/eximup didnt help :(
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    The problem with digging up an old thread is that the orignal information is log out of date, like in this case.

    Exactly what error are you getting, under what circumstances and what version of exim are you running?

    Before you do that, check that you do not have WHM > Tweak Settings > Prevent the user 'nobody' from sending out mail to remote addresses > enabled. And that you do have a valid email address in each field of WHM > Change System Mail Preferences >
     
Loading...

Share This Page