Shanta

Member
Mar 7, 2006
14
0
151
Enderby BC
Hi

I am attempting to get apache to redirect the cgi directory.

On my old server using WebMin/Virtualin I could simply edit the domains setup

Ie the ScriptAlias

If I wanted the site to have some of its own cgi I would use symlinks in the cgi directory.

The cPannel configuration is different.

symliks don't work and the ScriptAlias directive also dose not work.


Is this due to the fact that apache runs as nobody and each domain as the user?

The Webmin configuration ran as www_data and there were no individual user settings.

How do I set the cpanel system to allow me to run scripts in another cgi directory?

Can I do this through WMH or do I have to edit the files directly?

Thanks
Shanta
 

cPanelDavidG

Technical Product Specialist
Nov 29, 2006
11,212
13
313
Houston, TX
cPanel Access Level
Root Administrator
Hi

I am attempting to get apache to redirect the cgi directory.

On my old server using WebMin/Virtualin I could simply edit the domains setup

Ie the ScriptAlias

If I wanted the site to have some of its own cgi I would use symlinks in the cgi directory.

The cPannel configuration is different.

symliks don't work and the ScriptAlias directive also dose not work.


Is this due to the fact that apache runs as nobody and each domain as the user?

The Webmin configuration ran as www_data and there were no individual user settings.

How do I set the cpanel system to allow me to run scripts in another cgi directory?

Can I do this through WMH or do I have to edit the files directly?

Thanks
Shanta
You would need to edit httpd.conf to effect this change. However, be sure not to edit some portions of httpd.conf directly. You can read more about this at: CustomDirectives < EasyApache3 < TWiki