The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Redirect problem - adds trailing slash in CP 11 - bug?

Discussion in 'General Discussion' started by froglen, Aug 16, 2007.

  1. froglen

    froglen Member

    Joined:
    Aug 30, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hi.

    I wonder if we're doing something incorrectly or whether anyone else has noticed this but when we try to set up a customer redirect to a specific URL CPanel inserts a trailing slash. So therefore we can only forward to a directory and not to a URL referencing a file.

    eg

    "
    Add Redirect:

    A permanent redirect will notify the visitor's browser to update any bookmarks that are linked to the page that is being redirected. Temporary redirects will not update the visitor's bookmarks.

    We're entering:
    Type - temporary
    http://www.SELECTEDDOMAIN.com/ / {EMPTY}
    redirects to: http://www.ANOTHERDOMAIN.com/SpecificUrl.html
    & selecting WILD CARD option.

    CP acknowledges the redirection request by confirming the redirected URL without a slash but when user displays a list of the active redirects CP has added a slash to it. Actual redirection requests fail because the server to which customer is trying to redirect doesn't have a directory called "SpecificUrl.html", only a file of the same name.

    We are running: WHM 11.2.0 cPanel 11.10.0-R16391
    CENTOS Enterprise 5 i686 - WHM X v3.1.0

    Any ideas? Thanks folks!
     
  2. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
  3. froglen

    froglen Member

    Joined:
    Aug 30, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Still busted though.

    Thanks, it appears to be still broken in the latest stable:
    WHM 11.2.0 cPanel 11.10.0-R16448
    CENTOS Enterprise 5 i686 - WHM X v3.1.0

    Also what's the logic behind add-on domains creating a sub-domain of the domain associated with the account? That seems like a very dated configuration.
     
  4. froglen

    froglen Member

    Joined:
    Aug 30, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Broken condition occurs when wildcard forward requested

    The trailing slash seems to be inserted when selecting "WILDCARD REDIRECT" option and appears to be fixed in newest release otherwise.
     
  5. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Correct, the latest builds fix this issue.
     
  6. borealphil

    borealphil Member

    Joined:
    Oct 21, 2005
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    I use cPanel 11.24.4-R35075 and it adds a trailing slash whan I use the x skin. It does not add a trailing slash with x3 skin. But I still use the x skin, so it bothers me a little bit.

    The problem that I have is I want to redirect to this adress
    http://domain.cxm/gallery/view.php?gid=17
    but it adds a trailing slash and it does not work. Also, it does not display the redirect properly in the x skin interface, probably because of the "?" and "=" character.
     
  7. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    The old x theme is no longer maintained. You may wish to use the x style of the x3 theme instead so you have the updates and functionality of x3 but with the look and feel of x.
     
  8. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    765
    Likes Received:
    1
    Trophy Points:
    18
    I'm using cPanel 11.24.4-R36167 and just had a customer with this problem. X3 theme.

    He tried to redirect to a file and it ended up as

    http://mydomain.com/index.html/

    That was without using the wildcard option.
     
    #8 4u123, Jun 15, 2009
    Last edited: Jun 15, 2009
  9. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    I recommend submitting a support ticket so we can determine what is causing that trailing slash: http://tickets.cpanel.net/submit
     
  10. mattdmin

    mattdmin Member

    Joined:
    Nov 28, 2008
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
Loading...

Share This Page