The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Redirect proxy subdomain

Discussion in 'Security' started by plinet, May 2, 2017.

  1. plinet

    plinet Member

    Joined:
    Apr 15, 2017
    Messages:
    6
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Slovakia
    cPanel Access Level:
    Website Owner
    Hi,
    can somebody tell me how to redirect http request on proxy subdomain to https?
     
  2. 24x7server

    24x7server Well-Known Member

    Joined:
    Apr 17, 2013
    Messages:
    1,399
    Likes Received:
    52
    Trophy Points:
    28
    Location:
    India
    cPanel Access Level:
    Root Administrator
  3. plinet

    plinet Member

    Joined:
    Apr 15, 2017
    Messages:
    6
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Slovakia
    cPanel Access Level:
    Website Owner
  4. coolcom

    coolcom Member

    Joined:
    Mar 3, 2005
    Messages:
    13
    Likes Received:
    3
    Trophy Points:
    153
    Hello plinet,

    You do not need to re-direct in .htaccess.

    Go to WHM>Server Configuration>Tweak Settings>Redirection

    Select "Choose the closest matched domain for which that the system has a valid certificate when redirecting from non-SSL to SSL URLs. Formerly known as “Always redirect to SSL/TLS” [?]" and turn ON (default)

    This will re-direct your non-SSL logins to the SSL login.
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,064
    Likes Received:
    1,287
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    In "WHM >> Tweak Settings", under the "Security" tab, verify the following option is enabled:

    Require SSL for cPanel Services

    This should result in access attempts to the non-https URL for proxy subdomains automatically redirecting to the secure URL.

    Thank you.
     
  6. plinet

    plinet Member

    Joined:
    Apr 15, 2017
    Messages:
    6
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Slovakia
    cPanel Access Level:
    Website Owner
    Hi,
    i am using engitron plugin so the auto redirecting is not working. But i figured it out. If somebody else need it, click on edit default.conf in engitron page, search for
    and in if statements change the default values with
    and its working now.:)
     
    cPanelMichael likes this.
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,064
    Likes Received:
    1,287
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    I'm happy to see the issue is now solved. Thank you for updating us with the outcome.
     
Loading...

Share This Page