The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Redirect SSL problems

Discussion in 'General Discussion' started by slev, Oct 22, 2008.

  1. slev

    slev Member

    Joined:
    Mar 25, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Hi

    Seems impossible to get help at the moment from my host or cpanel because I dont get my license direct from them :(

    Hope someone can help me here,

    I have a new server so I am migarating all accounts over from my old server, I have setup a different domain and server name and installed a SSL cert on

    server.mydoman.net the standard way and also through the services part but the problem is,

    In the tweak settings

    When visiting /cpanel or /whm or /webmail with SSL, you can choose to redirect to:

    SSL Certificate Name Hostname Origin Domain Name

    I have the redirect checked to SSL Certificate Name so when a user clicks for example

    http://www.theirdomain.org/webmail or /cpanel

    they should get redirected to

    https://server.mydomain.net which then connects them via the servers SSL Cert which is installed correctly.

    but they are not they are redirected to

    https://www.theirdomain.org:2096

    instead cpanel is not redirecting to the servers hostname and ssl cert etc as it should do no matter what settings I try, I have restarted all services and rebooted the server but it has made no difference and I have cleared my cache and tried 3 different pc's to check.

    I have also re-installed the ssl cert on both items twice.

    Using

    WHM 11.23.2 cPanel 11.23.6-R27698
    CENTOS Enterprise 5.2 i686 on standard - WHM X v3.1.0
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    You stated you configured:

    But did you also configure:

    ?
     
  3. slev

    slev Member

    Joined:
    Mar 25, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Hi David

    I have

    Always redirect users to the ssl/tls ports when visiting /cpanel, /webmail, etc.

    Ticked ( enabled )

    When visiting /cpanel or /whm or /webmail WITHOUT SSL, you can choose to redirect to: clicked on Origin Domain Name

    When visiting /cpanel or /whm or /webmail with SSL, you can choose to redirect to: clicked on SSL Certificate Name

    These are the same settings as my other server which redirects users correctly.

    Many Thanks

    ian
     
  4. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Based on the settings you provide, and the result you described in your original post - the server is doing exactly what you tell it to.

    Requests to http://example.com/webmail will redirect to https://example.com:2096 in accordance with your settings.

    Only if you type https://example.com/webmail will you be redirected to https://hostname:2096 based on your settings.

    If you want it to instead redirect to the server's hostname instead of the origin domain name for HTTP requests, change the setting for WITHOUT SSL to Hostname instead.
     
    #4 cPanelDavidG, Oct 22, 2008
    Last edited: Oct 22, 2008
  5. slev

    slev Member

    Joined:
    Mar 25, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Hi

    Thanks for the reply,

    This is the problem it does not do this, no matter what settings I try no redirects are going to the server name they stay on the customers domain name and come up with invalid ssl as its using https on the customers domain name and not the servers.

    I clear my pc's cache and tried 3 different pc's to make sure

    Thanks

    Ian
     
  6. DaveUsedToWorkHere

    DaveUsedToWorkHere Well-Known Member

    Joined:
    Dec 28, 2001
    Messages:
    689
    Likes Received:
    1
    Trophy Points:
    18
    Just to make sure, there's a SSL cert installed for cPanel/WHM/Webmail that you installed through the Manage Service SSL Certificates function in WHM, right?

    Please note that you can get support through the link in my signature. Just submit a request without signing in and grab the support access number from the Support Center in WebHost Manager.
     
  7. slev

    slev Member

    Joined:
    Mar 25, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Hi

    Yes i Installed it there and in the standard place and it works fine when i go direct to https://server.mydomain.net

    I'll submit a support ticket thanks for your help.

    Ian
     
Loading...

Share This Page