The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Redirecting mail Edit DNS Zone and MX Record

Discussion in 'Bind / DNS / Nameserver Issues' started by pubwvj, Mar 15, 2004.

  1. pubwvj

    pubwvj Active Member

    Joined:
    Mar 15, 2004
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    In the Mountains of Vermont
    I am attempting to set up several domains such that the mail from several of them is all redirected to one domain which will then handle all of the mail. Something like this:

    Original Domains: Mail Handling Domain:
    hollygraphicart.com ---> blacklightning.com
    flashmag.com
    bltoner.com

    First I tried simply using the "Edit an MX Entry" in WHM (WHM 9.1.0 cPanel 9.1.0-S73__RedHat 9 - WHM X v2.1.2) and changed the MX for each to be blacklightning.com and then I tested. That didn't work. Mail still went to the original domains.

    Next I tried doing the above using mail.blacklightning.com instead but that also didn't work and mail still went to the original domains rather than BlackLightning.com

    In each case I verified that the changes had been made.

    My host then gave me "Edit a DNS Zone" access but neither of us were able to get it working there either.

    I then reread the WHM manual (2nd time) but didn't get a clue. :(

    Does anyone have exactly what the DNS setup should look like in "Edit a DNS Zone" to accomplish this? A screen shot would be great.

    I have done it before, but under Plesk and I don't see why I'm flailing under WHM which is new to me.

    Thanks in advance!

    -Walter
    in Vermont

    I searched the archives here but didn't find a solution. Interestingly, the moderator might want to know, if you don't already, that MX can't be searched on because it is only 2 characters long and there is a 3 character minimum. Odd and a bit of a pain. don't know if that can be fixed... Hope so.
     
  2. Marty

    Marty Well-Known Member

    Joined:
    Oct 10, 2001
    Messages:
    630
    Likes Received:
    1
    Trophy Points:
    18
    Stop there, and then ssh to the server and

    pico -w /etc/localdomains

    Then comment out each of the three original domain names. Save and test.
     
  3. pubwvj

    pubwvj Active Member

    Joined:
    Mar 15, 2004
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    In the Mountains of Vermont
    Tried these two suggestions.
    No joy.

    Other ideas. It seems like this should be easy.
    One thought my service provider has suggested is that the problem may be that all of my domains are on the same host served by the same mail server. Previously (for the past decade) the mail server was on a different host.

    Thoughts? I have seen other people ask this question so it must already have been resolved... no?
     
  4. pubwvj

    pubwvj Active Member

    Joined:
    Mar 15, 2004
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    In the Mountains of Vermont
    Well, I've continued working with this. It seems that the MX is not working at all. Setting MX in CPanel or WHM to another domain on the same server or an entirely different server at a different NOC at a different host gives the same result - the MX setting is ignored. Ideas?
     
  5. pubwvj

    pubwvj Active Member

    Joined:
    Mar 15, 2004
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    In the Mountains of Vermont
Loading...

Share This Page