nadav123

Well-Known Member
Mar 2, 2020
159
18
18
Orlando, FL
cPanel Access Level
Root Administrator
Hello again.
i want to try Redis cache on my server, now i want to make sure the Easy Apache 4, not install any Redis pack.

i check WHM > Eazy Apache 4

don't have any Redis packeg ( not even offered)

now have this installation (this from Engintron):

i can do it very easy, but i want to make sure,
if cPanel recommended on it, or i must download redis from cPanel repesotory (or is not connected and i got confused)

i be glad to know if it is safe use this method,
or cPanel offered something more default from cPanel repertories?
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
12,499
1,971
363
cPanel Access Level
Root Administrator
On a test server, I installed Engintron and Redis, and confirmed that created the following package:

Code:
redis-5.0.3-5.module_el8.4.0+2583+b9845322.x86_64
I did confirm that Yum was able to remove that package normally with the standard "yum remove redis-5.0.3-5.module_el8.4.0+2583+b9845322.x86_64" command, so that does indeed work.
 

nadav123

Well-Known Member
Mar 2, 2020
159
18
18
Orlando, FL
cPanel Access Level
Root Administrator
wow bro you good :) thank you man, you all the time helping me, i appreciate that a lot.

OK I FOUND LITTLE BIT MORE INFO, MAYBE YOU HAVE REPO NEED DELETE, HE NOT ANSWER ME BUT HAVE CHANCE YOU HAVE DNF COMMEND AS WELL:

I NOT SURE BEACUSE WHEN YOU LOOK HERE:

YOU SEE DNF IS "IF" AND CENTOS 8.
I HAVE CENTOS 07 BUT I NOT SURE IF I AM CURRENT

ANTOHER THING:
YOU SEE ANOTHER REPO GOT INSTALLED:
(https://rpms.remirepo.net/enterprise/remi-release-7.rpm)

------------------------------

As you see he recommended removal pack, i didn't got him, but i look in Redis enetrprise and found this:

i think Redis create in the folder a uninstaller, because have repos and stuff need to be deleted as well.
not sure, if you have it on your new server, try to see if you have uninstaller.

and update me about the REPO. ( if you can of course )
if need delete it along with redis
 

nadav123

Well-Known Member
Mar 2, 2020
159
18
18
Orlando, FL
cPanel Access Level
Root Administrator
It installs a REPO cPRex look on the script:

the REPO name:
(https://rpms.remirepo.net/enterprise/remi-release-7.rpm)

NEED TO DELETE THE REPO AS WELL???

And what you think about this uninstaller:

Is in the docs of Redis enterprise,
MAYBE THE UNINSTALLER REMOVE THE REPO AS WELL?
IT CAN BE THE BEST PRACTICE TO REMOVE REDIS?
I JUST WANT TO BE SURE CPREX THIS WHY I DIG ON THE SUBJECT.

As you see i asked the Engintron developer as well,
waiting for answers, then i think i will start to run with that.
(i will install and uninstall a couple of times on a new VM until understanding 100% how to install and reinstall redis.)
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
12,499
1,971
363
cPanel Access Level
Root Administrator
It does add the repo before it installs the package, yes, since that package isn't included with the operating system repositories.

I don't think that uninstaller is present with the way Engintron handles the package. If it was, that would definitely be the way to go.
 

nadav123

Well-Known Member
Mar 2, 2020
159
18
18
Orlando, FL
cPanel Access Level
Root Administrator
cPRex i believe you right too, but still, if i delete Redis:
"yum remove redis"

i need to remove the repos as well?
Or it's not necessary?


And if i need to delete the REPO, to delete i with YUM as well?
Let's say:
"yum remove remi-release-7.rpm"
 
Last edited:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
12,499
1,971
363
cPanel Access Level
Root Administrator
There is no requirement to remove the repository. It will just sit there, unused, unless you want to install those packages again in the future. You certainly can remove it if you want, but it won't hurt anything for it to be idle.
 

nadav123

Well-Known Member
Mar 2, 2020
159
18
18
Orlando, FL
cPanel Access Level
Root Administrator
I fix it after reboot and i clean yum and rebuild with:
yum makecache

btw Engintron says IN THE BOTTOM:

" If you rebuild your cPanel's LAMP stack with EasyApache4, you should re-run this script. "

I Think its because of that,
So for the final please answer me only on that before i do it i will clarify with you:

I should run the Engintron / Redis installation script again, cPRex? ( i know YUM its APACHE4 )
i should run it again no?
 

nadav123

Well-Known Member
Mar 2, 2020
159
18
18
Orlando, FL
cPanel Access Level
Root Administrator
cPRex i love you, very much really.
but i have question hahahahaha ;)


i must last help and we have done i promise bro huh :)

ok another thing i found its this:

now if you look have:
vm.overcommit_memory = 1

this i already added don't have any problem,
but because cPanel, i little afraid to run the cmd for the KARNEL
"echo" command from Redis DOCS:

  • Make sure Redis won't be affected by the Linux kernel feature, transparent huge pages, otherwise it will impact greatly both memory usage and latency in a negative way. This is accomplished with the following command: echo madvise > /sys/kernel/mm/transparent_hugepage/enabled.


To run this too? its the last thing i swear not have more question after that :)

the full commend line if you didnt notice:
echo madvise > /sys/kernel/mm/transparent_hugepage/enabled.

Waiting you your approval :)
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
12,499
1,971
363
cPanel Access Level
Root Administrator
The only time I've seen this cause an issue is with MongoDB, although we don't support that software either. There are some more details on that here:


As long as the kernel works and isn't some custom version, cPanel itself doesn't care about that setting.
 

nadav123

Well-Known Member
Mar 2, 2020
159
18
18
Orlando, FL
cPanel Access Level
Root Administrator
So not to run
echo madvise > /sys/kernel/mm/transparent_hugepage/enabled.

in simple words huh :)

BY THE WHY, WHEN I RE RUN THE SCRIPT, I NEED TO RUN IT NOW TWICE, BETWEEN THEM TO REBOOT THE SERVER OR NOT?

btw i find 2 redis.conf
one is:
/etc/redis.conf

and in blue folder (i think is UNIX)
/etc/redis/redis.conf

each one of them is the configuration file?
i have problem in the log:
10852:C 11 May 2022 17:30:49.343 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
10852:C 11 May 2022 17:30:49.343 # Redis version=7.0.0, bits=64, commit=00000000, modified=0, pid=10852, just started
10852:C 11 May 2022 17:30:49.343 # Warning: no config file specified, using the default config. In order to specify a config file use redis-server /path/to/redis.conf
10852:M 11 May 2022 17:30:49.344 * Increased maximum number of open files to 10032 (it was originally set to 4096).
10852:M 11 May 2022 17:30:49.344 * monotonic clock: POSIX clock_gettime
10852:M 11 May 2022 17:30:49.345 # Warning: Could not create server TCP listening socket *:6379: bind: Address already in use
10852:M 11 May 2022 17:30:49.345 # Failed listening on port 6379 (TCP), aborting.

the TCP error i believe is IPv6, Google Cloud by default provide in the DNS IPv6 Records.
not sure.

but the "no config file specified"
i little afraid after i see 2 configuration file ( but is normal you have identical UNIX folder - like maria db )

if you can help, i know is outside of scoop, but Redis is super cool. and freaking fast.
 
Last edited:

nadav123

Well-Known Member
Mar 2, 2020
159
18
18
Orlando, FL
cPanel Access Level
Root Administrator
Ok, after explorer, little the software.

i tried configured the path configuration file, but is not possible:
Warning: no config file specified, using the default config. In order to specify a config file use redis-server /path/to/redis.conf

Have default file in UNIX folder can't be changed.
and no matter what i do i get this error in the cmd: redis-server
10852:C 11 May 2022 17:30:49.343 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
10852:C 11 May 2022 17:30:49.343 # Redis version=7.0.0, bits=64, commit=00000000, modified=0, pid=10852, just started
10852:C 11 May 2022 17:30:49.343 # Warning: no config file specified, using the default config. In order to specify a config file use redis-server /path/to/redis.conf
10852:M 11 May 2022 17:30:49.344 * Increased maximum number of open files to 10032 (it was originally set to 4096).
10852:M 11 May 2022 17:30:49.344 * monotonic clock: POSIX clock_gettime
10852:M 11 May 2022 17:30:49.345 # Warning: Could not create server TCP listening socket *:6379: bind: Address already in use
10852:M 11 May 2022 17:30:49.345 # Failed listening on port 6379 (TCP), aborting.



but is not the problem of the TCP
i was thinking in the start it is IPv6 connection (GCP offerd that by default in the DNS)

but we not have IPv6
so i try to change inside the redis.conf
127.0.0.1 -[::]1

only to 127.0.0.1 (IPv4 only)

but is not that as well..
i start suspect have 2 redis systems. (by default like MariaDB and MySQL):
10852:M 11 May 2022 17:30:49.345 # Warning: Could not create server TCP listening socket *:6379: bind: Address already in use
10852:M 11 May 2022 17:30:49.345 # Failed listening on port 6379 (TCP), aborting.

THE LOGO OF REDIS NOT APPEAR, ONLY WHEN I STOP REDIS (sudo service redis stop)

why i have double connection?
again, redis works, when i run redis-cli
is see 127.0.0.1:6379

So i dont understand each TCP connection is faild :/
GOT LOST PLEASE HELP IF YOU CAN, I KNOW IS LITTLE BIT OUT OF SCOOP BUT REDIS IS VERY GOOD SOFTWARE.
ITS ALREADY WORK AND I SURE THIS NOT SOMETHING SERIOUS, BUT I WAS PREFERS IT WILL BE PERFECT.
I KNOW IT NOT CPANEL, BUT THIS IS THE ONLY ISSUE I HAVE, THIS TCP CONNECTION:
 
Last edited:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
12,499
1,971
363
cPanel Access Level
Root Administrator
If you do make the kernel change it's a good idea to reboot the system just to be sure that is in place.

The "address already in use" error would normally mean that a service is already running on that port. You can use the "lsof" command to see what is running there, specifically with this syntax to check that port:

Code:
lsof -i:6379
I do think it's more likely that you have two redis systems trying to start at the same time, though.

One command you can run to determine which software controls the configuration file is this:

Code:
rpm -qf /etc/redis.conf
rpm -qf /etc/redis/redis.conf
That will show what RPM is associated with that file on the system, and could point you in the right direction to know which configuration file you need to edit, and which may be part of a duplicate installation.
 

nadav123

Well-Known Member
Mar 2, 2020
159
18
18
Orlando, FL
cPanel Access Level
Root Administrator
I AM THINKING! NOT SURE.
This time i was right... it's IPv6 and IPv4:


[[email protected] ~]# lsof -i:6379
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
redis-ser 2914 redis 6u IPv4 198059 0t0 TCP localhost:6379 (LISTEN)
redis-ser 2914 redis 7u IPv6 198060 0t0 TCP localhost:6379 (LISTEN)


AND THIS THE RPM, THE ONE OUTSIDE THE FOLDER IS NOTHING:
[[email protected] ~]# rpm -qf /etc/redis.conf
file /etc/redis.conf is not owned by any package
[[email protected] ~]# rpm -qf /etc/redis/redis.conf
redis-7.0.0-1.el7.remi.x86_64


it's because google cloud provide DNS records with IPv6 BY DEFAULT.
(we can't avoid that, when you open zone on GCP its automatically give you 4 records they IPv6 as well... - NOT IPs! is not your IPs! is the resolvers of the Google Cloud):
ns-cloud-a1.googledomains.com.
ns-cloud-a2.googledomains.com.
ns-cloud-a3.googledomains.com.
ns-cloud-a4.googledomains.com.

this belong to the Google Cloud Platform, not me, this the reason Redis read this IPv6.
Its not only Redis.
its Engintron
and
CSF see it as well.

i respond here as well and this guys respond like is normal have 2 configuration files:


i think the problem is in the defualt configuration file.

i look on: nano /etc/redis.conf
and the one on the folder too, they are the same.

Now, i suspect on the BIND option (this the default of redis):
bind 127.0.0.1 -::1

the -::1 its open to ALL THE IPs specilly for IPv6.

when i tried specified redis.conf:

redis-server /path/to/redis.conf

its not working.

i think when i will specify the config file and remove the -::1
warning will go away.

Please help, need your experience here.
if i am right,
just provide me the right way to specified the redis.conf file with redis-server cmd.

I WILL SPECIFY THE CONF AND GET BACK TO YOU WITH RESULTS.
 

nadav123

Well-Known Member
Mar 2, 2020
159
18
18
Orlando, FL
cPanel Access Level
Root Administrator
I am able to change it (bind option), but the conf in NANO not matching
and the redis-server commend not changing redis.conf

this after i sucssed remove the connection of the IPV6 BUT STILL WARNING TCP IS STAID AND I NOT SEE ALL THE LOGO OF REDIS WHEN I RUN redis-server:

```
[[email protected] ~]# lsof -i:6379
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
redis-ser 1105 redis 6u IPv4 18854 0t0 TCP localhost:6379 (LISTEN)
[[email protected] ~]# redis-server
3019:C 13 May 2022 03:36:43.366 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
3019:C 13 May 2022 03:36:43.366 # Redis version=7.0.0, bits=64, commit=00000000, modified=0, pid=3019, just started
3019:C 13 May 2022 03:36:43.366 # Warning: no config file specified, using the default config. In order to specify a config file use redis-server /path/to/redis.conf
3019:M 13 May 2022 03:36:43.367 * Increased maximum number of open files to 10032 (it was originally set to 4096).
3019:M 13 May 2022 03:36:43.367 * monotonic clock: POSIX clock_gettime
3019:M 13 May 2022 03:36:43.367 # Warning: Could not create server TCP listening socket *:6379: bind: Address already in use
3019:M 13 May 2022 03:36:43.367 # Failed listening on port 6379 (TCP), aborting.
```

still this TCP WARNING,
when i stop redis with:
systemctl stop redis

then you not see the error, but redis not working,
i suspect this is a problem between "service" to "systemctl"

and because both of them working with Redis, this connection twice from 2 systems (like MariaDB as i said in the start)

i tried the developer as well, but i don't think he understands me or what is cPanel:
 
Last edited: