Well-Known Member
Mar 2, 2020
Orlando, FL
cPanel Access Level
Root Administrator
i think you actually right all the way, i tried to delete Redis as engintron recommended me:
[[email protected] ~]# yum remove redis-server
Loaded plugins: fastestmirror, universal-hooks
No Match for argument: redis-server
No Packages marked for removal

no packages... something wired here, i think have 2 packeges, on is from is EPEL REPO, and one from the default cPanel Apache4.

i will delete both and run the script again, lets see what hepend.

i think the problem is the REPOS, you right all the way.
please help bro.

btw i delete redis but i still see the pack ( but now the pack is not remi-pack ):
Thank you for using cPanel & WHM!
[[email protected] ~]# yum list redis
Loaded plugins: fastestmirror, universal-hooks
Loading mirror speeds from cached hostfile
* EA4:
* EA4-experimental:
* cpanel-addons-production-feed:
* cpanel-plugins:
* base:
* epel:
* extras:
* remi-safe:
* updates:
Available Packages

its not got deleted, but redis not working.
this is after i did:

yum remove redis

Maybe Redis got installed from 2 different packs?
one via engintron script and one from apache4 (yum?)

but is so stoped what i say beacuse the installation script is YUM.
i got lost bro please help here.
Last edited:


Well-Known Member
Mar 2, 2020
Orlando, FL
cPanel Access Level
Root Administrator
Found the solution, Engintron script, not good.
i fix it and put him another script for removal:

i found out the TCP connection is not an error,
i think it's systemctl do the connection before redis-server on cPanel.
This is the same behavior of MySQL and MariaDB.

Is works great. And have only 1 configuration file ( the other one got blue light and symlink with default installation of Redis 7, with engintron script – amazing )
Even Google Cloud put on any VM SDK by default to Redis, so you can monitor him as well (this thing cPanel cant do as GCP do... it actually cools)

check me:

recommended you a lot invest on Redis in cPanel, it is maybe stronger than NGINX...
Combination of Engintron and Redis + cPanel and GCP…
Wow, i tell you i never was more happy than now.

Check my script in the link.
You will see i was right too, in the minute you will use my 2 scripts.

Have more couple of cool stuff can do with Redis, i recommended a lot for cPanel invest Redis as they did with NGINX.
Amazing software.

Really cPRex i recommended you buy a VM on GCP (JUST FOR FUN, THEY GIVE YOU 300 FREE, YOU CAN RUN VMS IN VERY CHIP 2X2)
Install cPanel and Redis on the cloud, you will be in shock.

More than that have Redis Enterprise and you can connect them if you want on AMAZON EC haha this is insane.
Google have it too, but only think about that you can connect you google cloud to AMAZON AWS with GCP toghter...!

btw, have a couple of configuration you MUST use on your Linux sysctl conf.
vm.overcommit and something like that:

i recommended using the removal script i create first.
Then reboot the server and install the new script i create for engintron (twice with break of 4 min give to redis warm up)
then reboot the server and run the script again twice.

You will see redis-server
and redis-server 1
in the installation process.
This because he creates some string to red-hat but i not understand in this thing so i keep it as it is and touch only his EOF code.

If you have redis-server 1.
Something got duplicate, and because the name server-redis is taken.
you got the 1.
its not good, RUN THE SCRIPT AGAIN.
Until you will see redis-server without the 1.

Then tell me how it is :)

Recommended for WordPress:
if you have WordPress, after that install this it will BOOM your site:

Trust me:

with Engintron of course install.
You will see it's insane.

If you do it on GCP, wow, you will not believe in what you will see. (it will remove costs as well, this is the next thing after NGINX)


Jurassic Moderator
Staff member
Oct 19, 2014
cPanel Access Level
Root Administrator
My assumption was correct - at this point Redis is still not supported and we do not have any documentation on this. These packages are part of future work that we're moving towards, and there will be an announcement at that time, as well as documentation, when it is officially supported.


Product Owner (EasyApache)
Staff member
Apr 19, 2004
cPanel Access Level
Root Administrator
Hey Folks!

You found a new product we're about ready to release! This is our initial release of container support in EA4. Currently we provide memcached and redis. You can read more about it on our official GitHub (Official docs soon to come).

Podman: GitHub - CpanelInc/ea-podman
Redis using Podman: ea-redis62/ at master · CpanelInc/ea-redis62
Memcached using Podman: ea-memcached16/ at master · CpanelInc/ea-memcached16

This should work on AlmaLinux 8 and Ubuntu. Let me know if you have any questions!
  • Like
Reactions: cPRex